]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Added C128 serial driver
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
61 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
63 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
65 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
66
67
68
69 ###############################################################################
70 #                          Documentation subpackage                           #
71 ###############################################################################
72
73 %package doc
74
75 Requires: %{name} = %{version}
76 Copyright: Freeware
77 Summary: Documentation for the cc65 C compiler
78 Group: Development/Languages
79
80 %description doc
81 This package contains the documentation for the cc65 C compiler, mostly
82 in HTML format. Other formats can be generated from the sources.
83
84 %files doc
85 %doc doc/*.html
86 %doc doc/compile.txt
87 %doc doc/grc.txt
88 %doc doc/internal.txt
89 %doc doc/newvers.txt
90 %doc samples
91 %doc src/ld65/cfg/*.cfg
92
93
94
95 ###############################################################################
96 #                             Apple ][ subpackage                             #
97 ###############################################################################
98
99 %package apple2
100 Requires: %{name} = %{version}
101 Copyright: Freeware
102 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
103 Group: Development/Languages
104
105 %description apple2
106 This package contains the header files and libraries needed to write
107 programs for the Apple ][ using the cc65 crosscompiler.
108
109 %files apple2
110 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
112 %attr(644,root,root)            /usr/lib/cc65/joy/a2-*.joy
113 %attr(644,root,root)            /usr/lib/cc65/tgi/a2-*.tgi
114
115
116
117 ###############################################################################
118 #                              Atari subpackage                               #
119 ###############################################################################
120
121 %package atari
122 Requires: %{name} = %{version}
123 Copyright: Freeware
124 Summary: Atari specific libraries and headers for the cc65 compiler.
125 Group: Development/Languages
126
127 %description atari
128 This package contains the header files and libraries needed to write
129 programs for the 8 bit Atari machines using the cc65 crosscompiler.
130
131 %files atari
132 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
133 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
134
135
136
137 ###############################################################################
138 #                            Oric Atmos subpackage                            #
139 ###############################################################################
140
141 %package atmos
142 Requires: %{name} = %{version}
143 Copyright: Freeware
144 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
145 Group: Development/Languages
146
147 %description atmos
148 This package contains the header files and libraries needed to write
149 programs for the Oric Atmos using the cc65 crosscompiler.
150
151 %files atmos
152 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
153 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
154
155
156
157 ###############################################################################
158 #                               C128 subpackage                               #
159 ###############################################################################
160
161 %package c128
162 Requires: %{name} = %{version}
163 Copyright: Freeware
164 Summary: C128 specific libraries and headers for the cc65 compiler.
165 Group: Development/Languages
166
167 %description c128
168 This package contains the header files and libraries needed to write
169 programs for the Commodore C128 using the cc65 crosscompiler.
170
171 %files c128
172 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
173 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
174 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
175 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
176 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.ser
177 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
178
179
180
181 ###############################################################################
182 #                                C16 subpackage                               #
183 ###############################################################################
184
185 %package c16
186 Requires: %{name} = %{version}
187 Copyright: Freeware
188 Summary: C16/116 specific libraries and headers for the cc65 compiler.
189 Group: Development/Languages
190
191 %description c16
192 This package contains the header files and libraries needed to write
193 programs for the Commodore C16/116 using the cc65 crosscompiler.
194
195 %files c16
196 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
197 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
198 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
199
200
201
202 ###############################################################################
203 #                               C64 subpackage                                #
204 ###############################################################################
205
206 %package c64
207 Requires: %{name} = %{version}
208 Copyright: Freeware
209 Summary: C64 specific libraries and headers for the cc65 compiler.
210 Group: Development/Languages
211
212 %description c64
213 This package contains the header files and libraries needed to write
214 programs for the Commodore C64 using the cc65 crosscompiler.
215
216 %files c64
217 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
218 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
219 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
220 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
221 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
222
223
224
225 ###############################################################################
226 #                              CBM510 subpackage                              #
227 ###############################################################################
228
229 %package cbm510
230 Requires: %{name} = %{version}
231 Copyright: Freeware
232 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
233 Group: Development/Languages
234
235 %description cbm510
236 This package contains the header files and libraries needed to write
237 programs for the Commodore CBM 510 (aka P500) using the cc65
238 crosscompiler.
239
240 %files cbm510
241 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
242 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
243 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
244 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
245
246
247
248 ###############################################################################
249 #                              CBM610 subpackage                              #
250 ###############################################################################
251
252 %package cbm610
253 Requires: %{name} = %{version}
254 Copyright: Freeware
255 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
256 Group: Development/Languages
257
258 %description cbm610
259 This package contains the header files and libraries needed to write
260 programs for the Commodore PET-II (CBM600/700) family of computers using
261 the cc65 crosscompiler.
262
263 %files cbm610
264 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
265 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
266 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
267
268
269
270 ###############################################################################
271 #                               GEOS subpackage                               #
272 ###############################################################################
273
274 %package geos
275 Requires: %{name} = %{version}
276 Copyright: Freeware
277 Summary: GEOS specific libraries and headers for the cc65 compiler.
278 Group: Development/Languages
279
280 %description geos
281 This package contains the header files and libraries needed to write
282 GEOS programs for the C64/C128 using the cc65 crosscompiler.
283
284 %files geos
285 %attr(755,root,root)            /usr/bin/grc
286 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
287 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
288 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
289 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
290 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
291 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
292 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
293
294
295
296 ###############################################################################
297 #                               NES subpackage                                #
298 ###############################################################################
299
300 %package nes
301 Requires: %{name} = %{version}
302 Copyright: Freeware
303 Summary: NES specific libraries and headers for the cc65 compiler.
304 Group: Development/Languages
305
306 %description nes
307 This package contains the header files and libraries needed to write
308 programs for the Nintendo Entertainment System using the cc65
309 crosscompiler.
310
311 %files nes
312 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
313 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
314
315
316
317 ###############################################################################
318 #                               PET subpackage                                #
319 ###############################################################################
320
321 %package pet
322 Requires: %{name} = %{version}
323 Copyright: Freeware
324 Summary: PET specific libraries and headers for the cc65 compiler.
325 Group: Development/Languages
326
327 %description pet
328 This package contains the header files and libraries needed to write
329 programs for the Commodore PET family of computers using the cc65
330 crosscompiler.
331
332 %files pet
333 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
334 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
335
336
337
338 ###############################################################################
339 #                              Plus/4 subpackage                              #
340 ###############################################################################
341
342 %package plus4
343 Requires: %{name} = %{version}
344 Copyright: Freeware
345 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
346 Group: Development/Languages
347
348 %description plus4
349 This package contains the header files and libraries needed to write
350 programs for the Commodore Plus/4 and C16/116 using the cc65
351 crosscompiler.
352
353 %files plus4
354 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
355 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
356 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
357
358
359
360 ###############################################################################
361 #                           Supervision subpackage                            #
362 ###############################################################################
363
364 %package supervision
365 Requires: %{name} = %{version}
366 Copyright: Freeware
367 Summary: Supervision specific libraries and headers for the cc65 compiler.
368 Group: Development/Languages
369
370 %description supervision
371 This package contains the header files and libraries needed to write
372 programs for the Supervision Game console using the cc65 crosscompiler.
373
374 %files supervision
375 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
376 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
377
378
379
380 ###############################################################################
381 #                              VIC20 subpackage                               #
382 ###############################################################################
383
384 %package vic20
385 Requires: %{name} = %{version}
386 Copyright: Freeware
387 Summary: VIC20 specific libraries and headers for the cc65 compiler.
388 Group: Development/Languages
389
390 %description vic20
391 This package contains the header files and libraries needed to write
392 programs for the Commodore VIC20 using the cc65 crosscompiler.
393
394 %files vic20
395 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
396 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
397 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
398
399
400
401 ###############################################################################
402 #                                    Build                                    #
403 ###############################################################################
404
405
406
407 %prep
408 %setup -q
409
410
411 %build
412 # Binaries
413 make -C src -f make/gcc.mak
414 # Libraries
415 make -C libsrc -s zap all
416 # Documentation
417 make -C doc html
418
419
420 %install
421 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,sys,tgi},joy,lib,tgi}}
422
423 # Binaries
424 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
425 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
426 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
427 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
428 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
429 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
430 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
431 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
432 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
433 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
434 # Libraries and includes
435 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
436 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
437 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
438 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
439 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
440 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
441 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
442 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
443
444 # Drivers
445 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
446 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
447 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
448
449
450 %clean
451 rm -rf $RPM_BUILD_ROOT
452
453
454
455 %changelog
456 * Sun Nov 02 2003 Ullrich von Bassewitz <uz@cc65.org>
457 - Added missing files after upgrade to rpm 4.2
458
459 * Sun Oct 19 2003 Ullrich von Bassewitz <uz@cc65.org>
460 - Move documentation into a separate doc package.
461
462 * Fri Oct 10 2003 Ullrich von Bassewitz <uz@cc65.org>
463 - Added the Supervision subpackage.
464
465 * Thu Oct 02 2003 Ullrich von Bassewitz <uz@cc65.org>
466 - Better cleanup.
467
468 * Thu Jun 12 2003 Ullrich von Bassewitz <uz@cc65.org>
469 - Added subdirectories of include/
470
471 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
472 - The Apple ][ has a joystick driver.
473 - Added the NES subpackage.
474
475 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
476 Added a subpackage for the Oric Atmos.
477
478 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
479 Added the object file conversion utility co65.
480
481 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
482 Updated the version number.
483
484 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
485 Changed location of TGI drivers, added EM drivers.
486
487 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
488 Added the C16 subpackage.
489
490 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
491 Added TGI stuff.
492
493 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
494 Update to version 2.8.0 of the compiler package.
495
496 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
497 Update to version 2.7.1 of the compiler package.
498
499 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
500 Update to version 2.7.0 of the compiler package.
501
502 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
503 Update to version 2.6.2 of the compiler package.
504
505 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
506 Update to version 2.6.1 of the compiler package.
507
508 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
509 Update for cc65 2.6.0 and RedHat 7.x
510
511 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
512 The GEOS include files were not installed, remove headegen.sh
513
514 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
515 Update to version 2.5.0 of the compiler package.
516
517 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
518 Update to version 2.4.1 of the compiler package.
519
520 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
521 Update to version 2.4.0 of the compiler package.
522
523 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
524 Update to version 2.3.1 of the compiler package.
525
526 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
527 Update to version 2.3.0 of the compiler package.
528
529 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
530 [2.2.1-2]
531 - changed to allow build as plain user
532 - `samples' are part of documentation, not part of library
533