]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Add C64 serial driver
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
61 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
63 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
65 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
66
67
68
69 ###############################################################################
70 #                          Documentation subpackage                           #
71 ###############################################################################
72
73 %package doc
74
75 Requires: %{name} = %{version}
76 Copyright: Freeware
77 Summary: Documentation for the cc65 C compiler
78 Group: Development/Languages
79
80 %description doc
81 This package contains the documentation for the cc65 C compiler, mostly
82 in HTML format. Other formats can be generated from the sources.
83
84 %files doc
85 %doc doc/*.html
86 %doc doc/compile.txt
87 %doc doc/grc.txt
88 %doc doc/internal.txt
89 %doc doc/newvers.txt
90 %doc samples
91 %doc src/ld65/cfg/*.cfg
92
93
94
95 ###############################################################################
96 #                             Apple ][ subpackage                             #
97 ###############################################################################
98
99 %package apple2
100 Requires: %{name} = %{version}
101 Copyright: Freeware
102 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
103 Group: Development/Languages
104
105 %description apple2
106 This package contains the header files and libraries needed to write
107 programs for the Apple ][ using the cc65 crosscompiler.
108
109 %files apple2
110 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
112 %attr(644,root,root)            /usr/lib/cc65/joy/a2-*.joy
113 %attr(644,root,root)            /usr/lib/cc65/tgi/a2-*.tgi
114
115
116
117 ###############################################################################
118 #                              Atari subpackage                               #
119 ###############################################################################
120
121 %package atari
122 Requires: %{name} = %{version}
123 Copyright: Freeware
124 Summary: Atari specific libraries and headers for the cc65 compiler.
125 Group: Development/Languages
126
127 %description atari
128 This package contains the header files and libraries needed to write
129 programs for the 8 bit Atari machines using the cc65 crosscompiler.
130
131 %files atari
132 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
133 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
134
135
136
137 ###############################################################################
138 #                            Oric Atmos subpackage                            #
139 ###############################################################################
140
141 %package atmos
142 Requires: %{name} = %{version}
143 Copyright: Freeware
144 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
145 Group: Development/Languages
146
147 %description atmos
148 This package contains the header files and libraries needed to write
149 programs for the Oric Atmos using the cc65 crosscompiler.
150
151 %files atmos
152 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
153 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
154
155
156
157 ###############################################################################
158 #                               C128 subpackage                               #
159 ###############################################################################
160
161 %package c128
162 Requires: %{name} = %{version}
163 Copyright: Freeware
164 Summary: C128 specific libraries and headers for the cc65 compiler.
165 Group: Development/Languages
166
167 %description c128
168 This package contains the header files and libraries needed to write
169 programs for the Commodore C128 using the cc65 crosscompiler.
170
171 %files c128
172 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
173 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
174 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
175 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
176 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
177 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
178
179
180
181 ###############################################################################
182 #                                C16 subpackage                               #
183 ###############################################################################
184
185 %package c16
186 Requires: %{name} = %{version}
187 Copyright: Freeware
188 Summary: C16/116 specific libraries and headers for the cc65 compiler.
189 Group: Development/Languages
190
191 %description c16
192 This package contains the header files and libraries needed to write
193 programs for the Commodore C16/116 using the cc65 crosscompiler.
194
195 %files c16
196 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
197 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
198 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
199
200
201
202 ###############################################################################
203 #                               C64 subpackage                                #
204 ###############################################################################
205
206 %package c64
207 Requires: %{name} = %{version}
208 Copyright: Freeware
209 Summary: C64 specific libraries and headers for the cc65 compiler.
210 Group: Development/Languages
211
212 %description c64
213 This package contains the header files and libraries needed to write
214 programs for the Commodore C64 using the cc65 crosscompiler.
215
216 %files c64
217 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
218 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
219 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
220 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
221 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
222 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
223
224
225
226 ###############################################################################
227 #                              CBM510 subpackage                              #
228 ###############################################################################
229
230 %package cbm510
231 Requires: %{name} = %{version}
232 Copyright: Freeware
233 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
234 Group: Development/Languages
235
236 %description cbm510
237 This package contains the header files and libraries needed to write
238 programs for the Commodore CBM 510 (aka P500) using the cc65
239 crosscompiler.
240
241 %files cbm510
242 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
243 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
244 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
245 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
246
247
248
249 ###############################################################################
250 #                              CBM610 subpackage                              #
251 ###############################################################################
252
253 %package cbm610
254 Requires: %{name} = %{version}
255 Copyright: Freeware
256 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
257 Group: Development/Languages
258
259 %description cbm610
260 This package contains the header files and libraries needed to write
261 programs for the Commodore PET-II (CBM600/700) family of computers using
262 the cc65 crosscompiler.
263
264 %files cbm610
265 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
266 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
267 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
268
269
270
271 ###############################################################################
272 #                               GEOS subpackage                               #
273 ###############################################################################
274
275 %package geos
276 Requires: %{name} = %{version}
277 Copyright: Freeware
278 Summary: GEOS specific libraries and headers for the cc65 compiler.
279 Group: Development/Languages
280
281 %description geos
282 This package contains the header files and libraries needed to write
283 GEOS programs for the C64/C128 using the cc65 crosscompiler.
284
285 %files geos
286 %attr(755,root,root)            /usr/bin/grc
287 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
288 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
289 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
290 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
291 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
292 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
293 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
294
295
296
297 ###############################################################################
298 #                               NES subpackage                                #
299 ###############################################################################
300
301 %package nes
302 Requires: %{name} = %{version}
303 Copyright: Freeware
304 Summary: NES specific libraries and headers for the cc65 compiler.
305 Group: Development/Languages
306
307 %description nes
308 This package contains the header files and libraries needed to write
309 programs for the Nintendo Entertainment System using the cc65
310 crosscompiler.
311
312 %files nes
313 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
314 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
315
316
317
318 ###############################################################################
319 #                               PET subpackage                                #
320 ###############################################################################
321
322 %package pet
323 Requires: %{name} = %{version}
324 Copyright: Freeware
325 Summary: PET specific libraries and headers for the cc65 compiler.
326 Group: Development/Languages
327
328 %description pet
329 This package contains the header files and libraries needed to write
330 programs for the Commodore PET family of computers using the cc65
331 crosscompiler.
332
333 %files pet
334 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
335 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
336
337
338
339 ###############################################################################
340 #                              Plus/4 subpackage                              #
341 ###############################################################################
342
343 %package plus4
344 Requires: %{name} = %{version}
345 Copyright: Freeware
346 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
347 Group: Development/Languages
348
349 %description plus4
350 This package contains the header files and libraries needed to write
351 programs for the Commodore Plus/4 and C16/116 using the cc65
352 crosscompiler.
353
354 %files plus4
355 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
356 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
357 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
358
359
360
361 ###############################################################################
362 #                           Supervision subpackage                            #
363 ###############################################################################
364
365 %package supervision
366 Requires: %{name} = %{version}
367 Copyright: Freeware
368 Summary: Supervision specific libraries and headers for the cc65 compiler.
369 Group: Development/Languages
370
371 %description supervision
372 This package contains the header files and libraries needed to write
373 programs for the Supervision Game console using the cc65 crosscompiler.
374
375 %files supervision
376 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
377 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
378
379
380
381 ###############################################################################
382 #                              VIC20 subpackage                               #
383 ###############################################################################
384
385 %package vic20
386 Requires: %{name} = %{version}
387 Copyright: Freeware
388 Summary: VIC20 specific libraries and headers for the cc65 compiler.
389 Group: Development/Languages
390
391 %description vic20
392 This package contains the header files and libraries needed to write
393 programs for the Commodore VIC20 using the cc65 crosscompiler.
394
395 %files vic20
396 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
397 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
398 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
399
400
401
402 ###############################################################################
403 #                                    Build                                    #
404 ###############################################################################
405
406
407
408 %prep
409 %setup -q
410
411
412 %build
413 # Binaries
414 make -C src -f make/gcc.mak
415 # Libraries
416 make -C libsrc -s zap all
417 # Documentation
418 make -C doc html
419
420
421 %install
422 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,sys,tgi},joy,lib,ser,tgi}}
423
424 # Binaries
425 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
426 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
427 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
428 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
429 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
430 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
431 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
432 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
433 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
434 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
435 # Libraries and includes
436 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
437 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
438 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
439 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
440 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
441 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
442 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
443 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
444
445 # Drivers
446 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
447 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
448 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
449 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
450
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455
456
457 %changelog
458 * Sun Nov 02 2003 Ullrich von Bassewitz <uz@cc65.org>
459 - Added missing files after upgrade to rpm 4.2
460
461 * Sun Oct 19 2003 Ullrich von Bassewitz <uz@cc65.org>
462 - Move documentation into a separate doc package.
463
464 * Fri Oct 10 2003 Ullrich von Bassewitz <uz@cc65.org>
465 - Added the Supervision subpackage.
466
467 * Thu Oct 02 2003 Ullrich von Bassewitz <uz@cc65.org>
468 - Better cleanup.
469
470 * Thu Jun 12 2003 Ullrich von Bassewitz <uz@cc65.org>
471 - Added subdirectories of include/
472
473 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
474 - The Apple ][ has a joystick driver.
475 - Added the NES subpackage.
476
477 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
478 Added a subpackage for the Oric Atmos.
479
480 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
481 Added the object file conversion utility co65.
482
483 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
484 Updated the version number.
485
486 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
487 Changed location of TGI drivers, added EM drivers.
488
489 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
490 Added the C16 subpackage.
491
492 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
493 Added TGI stuff.
494
495 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
496 Update to version 2.8.0 of the compiler package.
497
498 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
499 Update to version 2.7.1 of the compiler package.
500
501 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
502 Update to version 2.7.0 of the compiler package.
503
504 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
505 Update to version 2.6.2 of the compiler package.
506
507 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
508 Update to version 2.6.1 of the compiler package.
509
510 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
511 Update for cc65 2.6.0 and RedHat 7.x
512
513 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
514 The GEOS include files were not installed, remove headegen.sh
515
516 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
517 Update to version 2.5.0 of the compiler package.
518
519 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
520 Update to version 2.4.1 of the compiler package.
521
522 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
523 Update to version 2.4.0 of the compiler package.
524
525 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
526 Update to version 2.3.1 of the compiler package.
527
528 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
529 Update to version 2.3.0 of the compiler package.
530
531 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
532 [2.2.1-2]
533 - changed to allow build as plain user
534 - `samples' are part of documentation, not part of library
535