]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
New linker config for the VIC-20 with 32K cartridge by Stefan Haubenthal.
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.13.0
15 Version: %{version}
16 Release: 1
17 License: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 URL: http://www.cc65.org/
23 %ifos linux
24 BuildRequires: perl
25 BuildRequires: sgml-tools
26 %endif
27 BuildRoot: /var/tmp/%{name}-%{version}
28
29 %description
30 A C crosscompiler for 6502 systems, including a macroassembler that
31 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
32 other tools. To create programs for one of the supported target
33 machines, you have to install at least one of the library packages.
34
35 %files
36 %defattr(644,root,root,755)
37 %doc announce.txt
38 %doc doc/BUGS
39 %doc doc/CREDITS
40 %doc doc/readme.1st
41 %attr(755,root,root)            /usr/bin/ar65
42 %attr(755,root,root)            /usr/bin/ca65
43 %attr(755,root,root)            /usr/bin/ca65html
44 %attr(755,root,root)            /usr/bin/cc65
45 %attr(755,root,root)            /usr/bin/cl65
46 %attr(755,root,root)            /usr/bin/co65
47 %attr(755,root,root)            /usr/bin/da65
48 %attr(755,root,root)            /usr/bin/ld65
49 %attr(755,root,root)            /usr/bin/od65
50 %attr(755,root,root) %dir       /usr/lib/cc65
51 %attr(755,root,root) %dir       /usr/lib/cc65/emd
52 %attr(755,root,root) %dir       /usr/lib/cc65/joy
53 %attr(755,root,root) %dir       /usr/lib/cc65/lib
54 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
55 %attr(755,root,root) %dir       /usr/lib/cc65/include
56 %attr(644,root,root)            /usr/lib/cc65/include/*.h
57 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
58 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
59 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
60 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
61 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
62 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
63 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
64 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
65 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
66 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
67 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
68 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
69
70
71
72 ###############################################################################
73 #                          Documentation subpackage                           #
74 ###############################################################################
75
76 %package doc
77
78 Requires: %{name} = %{version}
79 License: Freeware
80 Summary: Documentation for the cc65 C compiler
81 Group: Development/Languages
82
83 %description doc
84 This package contains the documentation for the cc65 C compiler, mostly
85 in HTML format. Other formats can be generated from the sources.
86
87 %files doc
88 %doc doc/*.html
89 %doc doc/compile.txt
90 %doc doc/internal.txt
91 %doc doc/newvers.txt
92 %doc samples
93
94
95
96 ###############################################################################
97 #                             Apple ][ subpackage                             #
98 ###############################################################################
99
100 %package apple2
101 Requires: %{name} = %{version}
102 License: Freeware
103 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
104 Group: Development/Languages
105
106 %description apple2
107 This package contains the header files and libraries needed to write
108 programs for the Apple ][ using the cc65 crosscompiler.
109
110 %files apple2
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
112 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
113 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
114 %attr(644,root,root)            /usr/lib/cc65/mou/a2.*.mou
115 %attr(644,root,root)            /usr/lib/cc65/ser/a2.*.ser
116 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
117 %attr(644,root,root)            /usr/lib/cc65/cfg/apple2-*.cfg
118
119
120
121 ###############################################################################
122 #                            Apple //e subpackage                             #
123 ###############################################################################
124
125 %package apple2enh
126 Requires: %{name} = %{version}
127 License: Freeware
128 Summary: Apple //e specific libraries and headers for the cc65 compiler.
129 Group: Development/Languages
130
131 %description apple2enh
132 This package contains the header files and libraries needed to write
133 programs for the Apple //e using the cc65 crosscompiler.
134
135 %files apple2enh
136 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
137 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
138 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
139 %attr(644,root,root)            /usr/lib/cc65/mou/a2e.*.mou
140 %attr(644,root,root)            /usr/lib/cc65/ser/a2e.*.ser
141 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
142
143
144
145 ###############################################################################
146 #                              Atari subpackage                               #
147 ###############################################################################
148
149 %package atari
150 Requires: %{name} = %{version}
151 License: Freeware
152 Summary: Atari specific libraries and headers for the cc65 compiler.
153 Group: Development/Languages
154
155 %description atari
156 This package contains the header files and libraries needed to write
157 programs for the 8 bit Atari machines using the cc65 crosscompiler.
158
159 %files atari
160 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
161 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
162
163
164
165 ###############################################################################
166 #                            Oric Atmos subpackage                            #
167 ###############################################################################
168
169 %package atmos
170 Requires: %{name} = %{version}
171 License: Freeware
172 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
173 Group: Development/Languages
174
175 %description atmos
176 This package contains the header files and libraries needed to write
177 programs for the Oric Atmos using the cc65 crosscompiler.
178
179 %files atmos
180 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
181 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
182
183
184
185 ###############################################################################
186 #                               C128 subpackage                               #
187 ###############################################################################
188
189 %package c128
190 Requires: %{name} = %{version}
191 License: Freeware
192 Summary: C128 specific libraries and headers for the cc65 compiler.
193 Group: Development/Languages
194
195 %description c128
196 This package contains the header files and libraries needed to write
197 programs for the Commodore C128 using the cc65 crosscompiler.
198
199 %files c128
200 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
201 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
202 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
203 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
204 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
205 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
206
207
208
209 ###############################################################################
210 #                                C16 subpackage                               #
211 ###############################################################################
212
213 %package c16
214 Requires: %{name} = %{version}
215 License: Freeware
216 Summary: C16/116 specific libraries and headers for the cc65 compiler.
217 Group: Development/Languages
218
219 %description c16
220 This package contains the header files and libraries needed to write
221 programs for the Commodore C16/116 using the cc65 crosscompiler.
222
223 %files c16
224 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
225 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
226 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
227
228
229
230 ###############################################################################
231 #                               C64 subpackage                                #
232 ###############################################################################
233
234 %package c64
235 Requires: %{name} = %{version}
236 License: Freeware
237 Summary: C64 specific libraries and headers for the cc65 compiler.
238 Group: Development/Languages
239
240 %description c64
241 This package contains the header files and libraries needed to write
242 programs for the Commodore C64 using the cc65 crosscompiler.
243
244 %files c64
245 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
246 %attr(644,root,root)            /usr/lib/cc65/emd/dtv-*.emd
247 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
248 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
249 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
250 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
251 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
252
253
254
255 ###############################################################################
256 #                              CBM510 subpackage                              #
257 ###############################################################################
258
259 %package cbm510
260 Requires: %{name} = %{version}
261 License: Freeware
262 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
263 Group: Development/Languages
264
265 %description cbm510
266 This package contains the header files and libraries needed to write
267 programs for the Commodore CBM 510 (aka P500) using the cc65
268 crosscompiler.
269
270 %files cbm510
271 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
272 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
273 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
274 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
275
276
277
278 ###############################################################################
279 #                              CBM610 subpackage                              #
280 ###############################################################################
281
282 %package cbm610
283 Requires: %{name} = %{version}
284 License: Freeware
285 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
286 Group: Development/Languages
287
288 %description cbm610
289 This package contains the header files and libraries needed to write
290 programs for the Commodore PET-II (CBM600/700) family of computers using
291 the cc65 crosscompiler.
292
293 %files cbm610
294 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
295 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
296 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
297
298
299
300 ###############################################################################
301 #                               GEOS subpackage                               #
302 ###############################################################################
303
304 %package geos
305 Requires: %{name} = %{version}
306 License: Freeware
307 Summary: GEOS specific libraries and headers for the cc65 compiler.
308 Group: Development/Languages
309
310 %description geos
311 This package contains the header files and libraries needed to write
312 GEOS programs for the C64/C128 using the cc65 crosscompiler.
313
314 %files geos
315 %attr(755,root,root)            /usr/bin/grc
316 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
317 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
318 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
319 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
320 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
321 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
322
323
324
325 ###############################################################################
326 #                               Lynx subpackage                               #
327 ###############################################################################
328
329 %package lynx
330 Requires: %{name} = %{version}
331 License: Freeware
332 Summary: Lynx specific libraries and headers for the cc65 compiler.
333 Group: Development/Languages
334
335 %description lynx
336 This package contains the header files and libraries needed to write
337 programs for the Lynx Game Console using the cc65 crosscompiler.
338
339 %files lynx
340 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
341 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
342 %attr(644,root,root)            /usr/lib/cc65/ser/lynx-*.ser
343 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
344
345
346
347 ###############################################################################
348 #                               NES subpackage                                #
349 ###############################################################################
350
351 %package nes
352 Requires: %{name} = %{version}
353 License: Freeware
354 Summary: NES specific libraries and headers for the cc65 compiler.
355 Group: Development/Languages
356
357 %description nes
358 This package contains the header files and libraries needed to write
359 programs for the Nintendo Entertainment System using the cc65
360 crosscompiler.
361
362 %files nes
363 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
364 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
365
366
367
368 ###############################################################################
369 #                               PET subpackage                                #
370 ###############################################################################
371
372 %package pet
373 Requires: %{name} = %{version}
374 License: Freeware
375 Summary: PET specific libraries and headers for the cc65 compiler.
376 Group: Development/Languages
377
378 %description pet
379 This package contains the header files and libraries needed to write
380 programs for the Commodore PET family of computers using the cc65
381 crosscompiler.
382
383 %files pet
384 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
385 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
386
387
388
389 ###############################################################################
390 #                              Plus/4 subpackage                              #
391 ###############################################################################
392
393 %package plus4
394 Requires: %{name} = %{version}
395 License: Freeware
396 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
397 Group: Development/Languages
398
399 %description plus4
400 This package contains the header files and libraries needed to write
401 programs for the Commodore Plus/4 and C16/116 using the cc65
402 crosscompiler.
403
404 %files plus4
405 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
406 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
407 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
408
409
410
411 ###############################################################################
412 #                           Supervision subpackage                            #
413 ###############################################################################
414
415 %package supervision
416 Requires: %{name} = %{version}
417 License: Freeware
418 Summary: Supervision specific libraries and headers for the cc65 compiler.
419 Group: Development/Languages
420
421 %description supervision
422 This package contains the header files and libraries needed to write
423 programs for the Supervision Game console using the cc65 crosscompiler.
424
425 %files supervision
426 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
427 %attr(644,root,root)            /usr/lib/cc65/cfg/supervision-*.cfg
428
429
430
431 ###############################################################################
432 #                              VIC20 subpackage                               #
433 ###############################################################################
434
435 %package vic20
436 Requires: %{name} = %{version}
437 License: Freeware
438 Summary: VIC20 specific libraries and headers for the cc65 compiler.
439 Group: Development/Languages
440
441 %description vic20
442 This package contains the header files and libraries needed to write
443 programs for the Commodore VIC20 using the cc65 crosscompiler.
444
445 %files vic20
446 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
447 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
448 %attr(644,root,root)            /usr/lib/cc65/cfg/vic20-*.cfg
449
450
451
452 ###############################################################################
453 #                                    Build                                    #
454 ###############################################################################
455
456
457
458 %prep
459 %setup -q
460
461
462 %build
463 # Binaries
464 make -C src -f make/gcc.mak
465 # Libraries
466 make -C libsrc -s zap all
467 # Documentation
468 make -C doc html
469
470
471 %install
472 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,cfg,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,ser,tgi}}
473
474 # Binaries
475 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
476 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
477 install    -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
478 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
479 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
480 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
481 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
482 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
483 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
484 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
485
486 # Libraries and includes
487 install -m 644 libsrc/*.lib $RPM_BUILD_ROOT/usr/lib/cc65/lib
488 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
489 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
490 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
491 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
492 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
493 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
494 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
495 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
496
497 # Additional linker configurations
498 for config in src/ld65/cfg/*-*.cfg; do
499     install -m 644 ${config} $RPM_BUILD_ROOT/usr/lib/cc65/cfg
500 done
501
502 # Drivers
503 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
504 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
505 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
506 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
507 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
508
509
510 %clean
511 rm -rf $RPM_BUILD_ROOT
512
513
514
515 %changelog
516 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
517 - Changelog is now in CVS