]> git.sur5r.net Git - minitube/blobdiff - debian/rules
Ship Google API key
[minitube] / debian / rules
index e5653ed63ba94346b958f7e6ad81ff6164fbcdbd..dcbf4c1832a0ef895ae7ddda2f2e0accf3df8a7b 100755 (executable)
@@ -1,11 +1,17 @@
 #!/usr/bin/make -f
 
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-export DEB_CFLAGS_MAINT_APPEND = -Wall
 export QT_SELECT=qt5
-include /usr/share/dpkg/buildflags.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/qmake.mk
 
+%:
+       dh $@
+
+override_dh_auto_configure::
+       dh_auto_configure -- DEFINES+=APP_GOOGLE_API_KEY=AIzaSyC9EDpL8xpx_EcAbTbn66wbMwMzqzSI3MM
+
+override_dh_auto_install::
+       dh_auto_install --destdir=debian/tmp
+
+override_dh_missing::
+       dh_missing --fail-missing
 
-# Add here any variable or target overrides you need.