]> git.sur5r.net Git - bacula/bacula/blob - bacula/platforms/rpm/bacula-mtx.spec
5b260cea604da342af9eeb73209a642e978e928b
[bacula/bacula] / bacula / platforms / rpm / bacula-mtx.spec
1 # Bacula RPM spec file
2 #
3 # Copyright (C) 2000-2010 Free Software Foundation Europe e.V.
4
5 # Platform Build Configuration
6
7 # basic defines for every build
8 %define _release           1
9 %define _version           5.0.3
10 %define depkgs_version     18Feb09
11 %define _packager D. Scott Barninger <barninger@fairfieldcomputers.com>
12
13 %define manpage_ext gz
14
15 %define single_dir 0
16 %{?single_dir_install:%define single_dir 1}
17
18 # Installation Directory locations
19 %define _prefix        /usr
20 %define _sbindir       %_prefix/sbin
21 %define _bindir        %_prefix/bin
22 %define _subsysdir     /var/lock/subsys
23 %define sqlite_bindir  %_libdir/bacula/sqlite
24 %define _mandir        %_prefix/share/man
25 %define sysconf_dir    /etc/bacula
26 %define script_dir     %_libdir/bacula
27 %define working_dir    /var/lib/bacula
28 %define pid_dir        /var/run
29 %define plugin_dir     %_libdir/bacula/plugins
30 %define lib_dir        %_libdir/bacula/lib
31
32 #--------------------------------------------------------------------------
33 # it should not be necessary to change anything below here for a release
34 # except for patch macros in the setup section
35 #--------------------------------------------------------------------------
36
37 %{?contrib_packager:%define _packager %{contrib_packager}}
38
39 Summary: Bacula - The Network Backup Solution
40 Name: bacula-mtx
41 Version: %{_version}
42 Release: %{_release}
43 Group: System Environment/Daemons
44 License: GPL v2
45 BuildRoot: %{_tmppath}/%{name}-root
46 URL: http://www.bacula.org/
47 Vendor: The Bacula Team
48 Packager: %{_packager}
49 Prefix: %{_prefix}
50 Distribution: Bacula Bat
51
52 Source: http://www.prdownloads.sourceforge.net/bacula/depkgs-%{depkgs_version}.tar.gz
53
54 # define the basic package description
55 %define blurb Bacula - The Leading Open Source Backup Solution.
56 %define blurb2 Bacula is a set of computer programs that permit you (or the system
57 %define blurb3 administrator) to manage backup, recovery, and verification of computer
58 %define blurb4 data across a network of computers of different kinds. In technical terms,
59 %define blurb5 it is a network client/server based backup program. Bacula is relatively
60 %define blurb6 easy to use and efficient, while offering many advanced storage management
61 %define blurb7 features that make it easy to find and recover lost or damaged files.
62 %define blurb8 Bacula source code has been released under the GPL version 2 license.
63
64 Summary: Bacula - The Network Backup Solution
65 Group: System Environment/Daemons
66
67 %description
68 %{blurb}
69
70 %{blurb2}
71 %{blurb3}
72 %{blurb4}
73 %{blurb5}
74 %{blurb6}
75 %{blurb7}
76 %{blurb8}
77
78 This is Bacula's version of mtx tape utilities for Linux distributions that
79 do not provide their own mtx package
80
81 %prep
82 %setup -T -n depkgs -b 0
83
84 %build
85
86 make mtx
87
88 %install
89 make \
90         prefix=$RPM_BUILD_ROOT%{_prefix} \
91         sbindir=$RPM_BUILD_ROOT%{_sbindir} \
92         sysconfdir=$RPM_BUILD_ROOT%{sysconf_dir} \
93         scriptdir=$RPM_BUILD_ROOT%{script_dir} \
94         working_dir=$RPM_BUILD_ROOT%{working_dir} \
95         piddir=$RPM_BUILD_ROOT%{pid_dir} \
96         mandir=$RPM_BUILD_ROOT%{_mandir} \
97         mtx-install
98
99 %files
100 %defattr(-,root,root)
101 %attr(-, root, %{storage_daemon_group}) %{_sbindir}/loaderinfo
102 %attr(-, root, %{storage_daemon_group}) %{_sbindir}/mtx
103 %attr(-, root, %{storage_daemon_group}) %{_sbindir}/scsitape
104 %attr(-, root, %{storage_daemon_group}) %{_sbindir}/tapeinfo
105 %attr(-, root, %{storage_daemon_group}) %{_sbindir}/scsieject
106 %{_mandir}/man1/loaderinfo.1.%{manpage_ext}
107 %{_mandir}/man1/mtx.1.%{manpage_ext}
108 %{_mandir}/man1/scsitape.1.%{manpage_ext}
109 %{_mandir}/man1/tapeinfo.1.%{manpage_ext}
110 %{_mandir}/man1/scsieject.1.%{manpage_ext}
111
112
113 %clean
114 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf "$RPM_BUILD_ROOT"
115 rm -rf $RPM_BUILD_DIR/depkgs
116
117 %changelog
118 * Sat Aug 1 2009 Kern Sibbald <kern@sibbald.com>
119 - Split mtx out into bacula-mtx.spec