]> git.sur5r.net Git - bacula/rescue/blobdiff - rescue/autoconf/configure.in
Updates
[bacula/rescue] / rescue / autoconf / configure.in
index f0a3d0dbebc08da810023fa18aeb6e5a3dfdf4a2..41e9e20744ccdf429c6879b4dd12f0a5e0d4c698 100644 (file)
@@ -90,27 +90,13 @@ dnl# --------------------------------------------------------------------------
 dnl# CHECKING COMMAND LINE OPTIONS
 dnl# --------------------------------------------------------------------------
 
-# -------------------------------------------
-# static-fd    (default off)
-# -------------------------------------------
-AC_ARG_ENABLE(static-fd,
-   [  --enable-static-fd      enable static File daemon [disabled]],
-   [if test x$enableval = xyes; then
-     support_static_fd=yes
-   fi])
-
-STATIC_FD=
-if test x$support_static_fd = xyes; then
-   STATIC_FD="static-bacula-fd"
-fi
-AC_SUBST(STATIC_FD)
 
 where=
 # ------------------------------------------
 # Where to get iso
 # ------------------------------------------
 AC_ARG_WITH(iso,
-   [  --with-iso=PATH   specify path to iso],
+   [  --with-iso=PATH   specify path to iso (not implemented)],
    [
        if test "x$withval" != "xno" ; then     
           where=$withval
@@ -136,6 +122,21 @@ AC_ARG_WITH(cdrom,
 AC_SUBST(where)
 AC_SUBST(type)
 
+
+# ------------------------------------------
+# Which kernel to take
+# ------------------------------------------
+AC_ARG_WITH(kernel,
+   [  --with-kernel=version  specify complete kernel version (e.g. 2.6.14-2) ],
+   [
+       if test "x$withval" != "xno" ; then     
+         KERNEL=$withval
+       fi
+   ]
+)
+AC_SUBST(KERNEL)
+
+
 # ------------------------------------------
 # Where to get Bacula source
 # ------------------------------------------
@@ -147,13 +148,25 @@ AC_ARG_WITH(bacula,
        fi
    ]
 )
-
-if test x${bacula} = x; then
-   AC_MSG_ERROR(Missing --with-bacula=PATH)
-fi
-
 AC_SUBST(bacula)
 
+STATIC_FD=
+# ------------------------------------------
+# Where to get static-bacula-fd
+# ------------------------------------------
+AC_ARG_WITH(static-fd,
+   [  --with-static-fd=PATH    specify path to static FD],
+   [
+       if test "x$withval" != "xno" ; then     
+         STATIC_FD=$withval
+       fi
+   ]
+)
+AC_SUBST(STATIC_FD)
+
+if test x${bacula} = x -a x${STATIC_FD} = x ; then
+   AC_MSG_ERROR(You must specify either --with-bacula=PATH or --with-static-fd=PATH)
+fi
 
 #
 # Finally we set appropriate distribution specific
@@ -274,9 +287,8 @@ Configuration on `date`:
   Host:                      $host -- ${DISTNAME} ${DISTVER}
   Rescue version:            ${VERSION} (${DATE})
   Source code location:       ${bacula}
-  Rescue disk image type:     ${type}
-  Rescue disk image location: ${where}
-
+  Static FD location:        ${STATIC_FD}
+  Specific kernel version:    ${KERNEL}
 
   " > config.out