]> git.sur5r.net Git - bacula/rescue/blobdiff - rescue/autoconf/configure.in
Integrate mkcdrec with Bacula
[bacula/rescue] / rescue / autoconf / configure.in
index 37fb26f47a8aa9eb5b33c0be6e00d1ee76d00c3e..25de3221caaefb9b63dd4dd5b3e15479824cbde3 100644 (file)
@@ -70,47 +70,49 @@ if test x${exec_prefix} = xNONE ; then
     exec_prefix=${prefix}
 fi
 
+# ------------------------------------------
+# What device to use
+# ------------------------------------------
+DEV=
+AC_ARG_WITH(dev,
+   [  --with-dev=DEVICE     specify device (e.g. /dev/hdc)],
+   [
+       if test "x$withval" != "xno" ; then     
+          DEV=$withval
+       fi
+   ]
+)
+
 # -------------------------------------------
-# check for cdrecord writer location
+# if no --with-dev given check for cdrecord writer location
 # get scsibus,target,lun
 # -------------------------------------------
-CDSTL="3,0,0"
-if test ! x$CDRECORD = x ; then
-   CDSTL=`${CDRECORD} -scanbus 2>/dev/null | grep CD-RW | ${AWK} '{print $1}'`
-   if test x${CDSTL} = x ; then
-      CDSTL=`${CDRECORD} -scanbus 2>/dev/null | grep CD+RW | ${AWK} '{print $1}'`
-   fi
-   if test x${CDSTL} = x ; then
-      CDSTL="3,0,0"
+if test x$DEV = x ; then
+   CDSTL="3,0,0"
+   if test ! x$CDRECORD = x ; then
+      CDSTL=`${CDRECORD} -scanbus 2>/dev/null | grep CD-RW | ${AWK} '{print $1}'`
+      if test x${CDSTL} = x ; then
+        CDSTL=`${CDRECORD} -scanbus 2>/dev/null | grep CD+RW | ${AWK} '{print $1}'`
+      fi
+      if test x${CDSTL} = x ; then
+        CDSTL="3,0,0"
+      fi
    fi
+   DEV="ATA:${CDSTL}"
 fi
-AC_SUBST(CDSTL)
+AC_SUBST(DEV)
 
 dnl# --------------------------------------------------------------------------
 dnl# CHECKING COMMAND LINE OPTIONS
 dnl# --------------------------------------------------------------------------
 
-# -------------------------------------------
-# static-fd    (default off)
-# -------------------------------------------
-AC_ARG_ENABLE(static-fd,
-   [  --enable-static-fd      enable static File daemon [disabled]],
-   [if test x$enableval = xyes; then
-     support_static_fd=yes
-   fi])
-
-STATIC_FD=
-if test x$support_static_fd = xyes; then
-   STATIC_FD="static-bacula-fd"
-fi
-AC_SUBST(STATIC_FD)
 
 where=
 # ------------------------------------------
 # Where to get iso
 # ------------------------------------------
 AC_ARG_WITH(iso,
-   [  --with-iso=PATH   specify path to iso],
+   [  --with-iso=PATH   specify path to iso (not implemented)],
    [
        if test "x$withval" != "xno" ; then     
           where=$withval
@@ -136,20 +138,81 @@ AC_ARG_WITH(cdrom,
 AC_SUBST(where)
 AC_SUBST(type)
 
+
+# ------------------------------------------
+# Which kernel to take
+# ------------------------------------------
+AC_ARG_WITH(kernel,
+   [  --with-kernel=version  specify complete kernel version (e.g. 2.6.14-2) ],
+   [
+       if test "x$withval" != "xno" ; then     
+         KERNEL=$withval
+       fi
+   ]
+)
+AC_SUBST(KERNEL)
+
+
 # ------------------------------------------
 # Where to get Bacula source
 # ------------------------------------------
 AC_ARG_WITH(bacula,
-   [  --with-bacula=PATH    specify path to bacula],
+   [  --with-bacula=PATH    specify path to Bacula source],
    [
        if test "x$withval" != "xno" ; then     
          bacula=$withval
        fi
    ]
 )
-
 AC_SUBST(bacula)
 
+STATIC_FD=
+# ------------------------------------------
+# Where to get static-bacula-fd
+# ------------------------------------------
+AC_ARG_WITH(static-fd,
+   [  --with-static-fd=PATH    specify path to static FD],
+   [
+       if test "x$withval" != "xno" ; then     
+         STATIC_FD=$withval
+       fi
+   ]
+)
+AC_SUBST(STATIC_FD)
+
+BACULA_BIN=
+# ------------------------------------------
+# Where to get Bacula binaries
+# ------------------------------------------
+AC_ARG_WITH(bacula-bin,
+   [  --with-bacula-bin=PATH   specify path to bacula binaries (NOT IMPLEMENTED)],
+   [
+       if test "x$withval" != "xno" ; then     
+         BACULA_BIN=$withval
+       fi
+   ]
+)
+AC_SUBST(BACULA_BIN)
+
+BACULA_SCRIPTS=
+# ------------------------------------------
+# Where to get Bacula scripts
+# ------------------------------------------
+AC_ARG_WITH(bacula-scripts,
+   [  --with-bacula-scripts=PATH    specify path to bacula scripts],
+   [
+       if test "x$withval" != "xno" ; then     
+         BACULA_SCRIPTS=$withval
+       fi
+   ]
+)
+AC_SUBST(BACULA_SCRIPTS)
+
+
+
+if test x${bacula} = x -a x${STATIC_FD} = x ; then
+   AC_MSG_ERROR(You must specify either --with-bacula=PATH or --with-static-fd=PATH)
+fi
 
 #
 # Finally we set appropriate distribution specific
@@ -249,30 +312,35 @@ dnl# common parts of the Makefile
 MCOMMON=./autoconf/Make.common
 AC_SUBST_FILE(MCOMMON)
 
+./build-depkgs
 
 AC_OUTPUT([    \
           autoconf/Make.common \
           Makefile \
           linux/Makefile \
-          linux/floppy/Makefile \
           linux/cdrom/Makefile \
           linux/cdrom/bacula/Makefile \
+          linux/cdrom/cdtree/boot/isolinux/boot.msg \
+          knoppix/cdrom/Makefile \
+          knoppix/cdrom/bacula/Makefile \
           freebsd/Makefile \
           solaris/Makefile \
           $PFILES ],  
          [ ]
 )
 
+  
 
 echo "
 Configuration on `date`:
 
   Host:                      $host -- ${DISTNAME} ${DISTVER}
   Rescue version:            ${VERSION} (${DATE})
+  Bacula scripts location:    ${BACULA_SCRIPTS}
   Source code location:       ${bacula}
-  Rescue disk image type:     ${type}
-  Rescue disk image location: ${where}
-
+  Static FD location:        ${STATIC_FD}
+  Specific kernel version:    ${KERNEL}
+  CDROM device:              ${DEV}
 
   " > config.out