]> git.sur5r.net Git - bacula/rescue/blobdiff - rescue/autoconf/configure.in
Integrate mkcdrec with Bacula
[bacula/rescue] / rescue / autoconf / configure.in
index 41e9e20744ccdf429c6879b4dd12f0a5e0d4c698..25de3221caaefb9b63dd4dd5b3e15479824cbde3 100644 (file)
@@ -70,21 +70,37 @@ if test x${exec_prefix} = xNONE ; then
     exec_prefix=${prefix}
 fi
 
+# ------------------------------------------
+# What device to use
+# ------------------------------------------
+DEV=
+AC_ARG_WITH(dev,
+   [  --with-dev=DEVICE     specify device (e.g. /dev/hdc)],
+   [
+       if test "x$withval" != "xno" ; then     
+          DEV=$withval
+       fi
+   ]
+)
+
 # -------------------------------------------
-# check for cdrecord writer location
+# if no --with-dev given check for cdrecord writer location
 # get scsibus,target,lun
 # -------------------------------------------
-CDSTL="3,0,0"
-if test ! x$CDRECORD = x ; then
-   CDSTL=`${CDRECORD} -scanbus 2>/dev/null | grep CD-RW | ${AWK} '{print $1}'`
-   if test x${CDSTL} = x ; then
-      CDSTL=`${CDRECORD} -scanbus 2>/dev/null | grep CD+RW | ${AWK} '{print $1}'`
-   fi
-   if test x${CDSTL} = x ; then
-      CDSTL="3,0,0"
+if test x$DEV = x ; then
+   CDSTL="3,0,0"
+   if test ! x$CDRECORD = x ; then
+      CDSTL=`${CDRECORD} -scanbus 2>/dev/null | grep CD-RW | ${AWK} '{print $1}'`
+      if test x${CDSTL} = x ; then
+        CDSTL=`${CDRECORD} -scanbus 2>/dev/null | grep CD+RW | ${AWK} '{print $1}'`
+      fi
+      if test x${CDSTL} = x ; then
+        CDSTL="3,0,0"
+      fi
    fi
+   DEV="ATA:${CDSTL}"
 fi
-AC_SUBST(CDSTL)
+AC_SUBST(DEV)
 
 dnl# --------------------------------------------------------------------------
 dnl# CHECKING COMMAND LINE OPTIONS
@@ -164,6 +180,36 @@ AC_ARG_WITH(static-fd,
 )
 AC_SUBST(STATIC_FD)
 
+BACULA_BIN=
+# ------------------------------------------
+# Where to get Bacula binaries
+# ------------------------------------------
+AC_ARG_WITH(bacula-bin,
+   [  --with-bacula-bin=PATH   specify path to bacula binaries (NOT IMPLEMENTED)],
+   [
+       if test "x$withval" != "xno" ; then     
+         BACULA_BIN=$withval
+       fi
+   ]
+)
+AC_SUBST(BACULA_BIN)
+
+BACULA_SCRIPTS=
+# ------------------------------------------
+# Where to get Bacula scripts
+# ------------------------------------------
+AC_ARG_WITH(bacula-scripts,
+   [  --with-bacula-scripts=PATH    specify path to bacula scripts],
+   [
+       if test "x$withval" != "xno" ; then     
+         BACULA_SCRIPTS=$withval
+       fi
+   ]
+)
+AC_SUBST(BACULA_SCRIPTS)
+
+
+
 if test x${bacula} = x -a x${STATIC_FD} = x ; then
    AC_MSG_ERROR(You must specify either --with-bacula=PATH or --with-static-fd=PATH)
 fi
@@ -266,6 +312,7 @@ dnl# common parts of the Makefile
 MCOMMON=./autoconf/Make.common
 AC_SUBST_FILE(MCOMMON)
 
+./build-depkgs
 
 AC_OUTPUT([    \
           autoconf/Make.common \
@@ -274,21 +321,26 @@ AC_OUTPUT([    \
           linux/cdrom/Makefile \
           linux/cdrom/bacula/Makefile \
           linux/cdrom/cdtree/boot/isolinux/boot.msg \
+          knoppix/cdrom/Makefile \
+          knoppix/cdrom/bacula/Makefile \
           freebsd/Makefile \
           solaris/Makefile \
           $PFILES ],  
          [ ]
 )
 
+  
 
 echo "
 Configuration on `date`:
 
   Host:                      $host -- ${DISTNAME} ${DISTVER}
   Rescue version:            ${VERSION} (${DATE})
+  Bacula scripts location:    ${BACULA_SCRIPTS}
   Source code location:       ${bacula}
   Static FD location:        ${STATIC_FD}
   Specific kernel version:    ${KERNEL}
+  CDROM device:              ${DEV}
 
   " > config.out