]> git.sur5r.net Git - glabels/blobdiff - glabels2/barcode-0.98/debian/rules
Organized master branch to be top-level directory for glabels, instead of
[glabels] / glabels2 / barcode-0.98 / debian / rules
diff --git a/glabels2/barcode-0.98/debian/rules b/glabels2/barcode-0.98/debian/rules
deleted file mode 100755 (executable)
index c48c5a1..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/usr/bin/make -f
-# Made with the aid of debmake, by Christoph Lameter,
-# based on the sample debian/rules file for GNU hello by Ian Jackson.
-
-package=barcode
-
-build:
-       $(checkdir)
-       ./configure --prefix=/usr
-       $(MAKE) CFLAGS="-O2 -g -Wall"
-       touch build
-
-clean:
-       $(checkdir)
-       -rm -f build
-       -$(MAKE) distclean
-       -rm -f `find . -name "*~"`
-       -rm -rf debian/tmp debian/files* core debian/substvars
-
-binary-indep: checkroot build
-       $(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package.  If there were any they would be
-# made here.
-
-binary-arch: checkroot build
-       $(checkdir)
-       -rm -rf debian/tmp
-       install -d debian/tmp
-       cd debian/tmp && install -d `cat ../dirs`
-       $(MAKE) install prefix=`pwd`/debian/tmp/usr
-# Must have debmake installed for this to work. Otherwise please copy
-# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
-       debstd ChangeLog README TODO INSTALL
-       dpkg-gencontrol
-       chown -R root.root debian/tmp
-       chmod -R go=rX debian/tmp
-       dpkg --build debian/tmp ..
-
-define checkdir
-       test -f debian/rules
-endef
-
-binary: binary-indep binary-arch
-
-checkroot:
-       $(checkdir)
-       test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot