]> git.sur5r.net Git - i3/i3/blob - parser-specs/config.spec
Optionally change i3bar color on focused output, implements #2020
[i3/i3] / parser-specs / config.spec
1 # vim:ts=2:sw=2:expandtab
2 #
3 # i3 - an improved dynamic tiling window manager
4 # © 2009 Michael Stapelberg and contributors (see also: LICENSE)
5 #
6 # parser-specs/config.spec: Specification file for generate-command-parser.pl
7 # which will generate the appropriate header files for our C parser.
8 #
9 # Use :source highlighting.vim in vim to get syntax highlighting
10 # for this file.
11
12 # TODO: should we implement an include statement for the criteria part so we DRY?
13
14 state INITIAL:
15   # We have an end token here for all the commands which just call some
16   # function without using an explicit 'end' token.
17   end ->
18   error ->
19   '#'                                      -> IGNORE_LINE
20   'set'                                    -> IGNORE_LINE
21   bindtype = 'bindsym', 'bindcode', 'bind' -> BINDING
22   'bar'                                    -> BARBRACE
23   'font'                                   -> FONT
24   'mode'                                   -> MODENAME
25   'floating_minimum_size'                  -> FLOATING_MINIMUM_SIZE_WIDTH
26   'floating_maximum_size'                  -> FLOATING_MAXIMUM_SIZE_WIDTH
27   'floating_modifier'                      -> FLOATING_MODIFIER
28   'default_orientation'                    -> DEFAULT_ORIENTATION
29   'workspace_layout'                       -> WORKSPACE_LAYOUT
30   windowtype = 'new_window', 'new_float'   -> NEW_WINDOW
31   'hide_edge_borders'                      -> HIDE_EDGE_BORDERS
32   'for_window'                             -> FOR_WINDOW
33   'assign'                                 -> ASSIGN
34   'no_focus'                               -> NO_FOCUS
35   'focus_follows_mouse'                    -> FOCUS_FOLLOWS_MOUSE
36   'mouse_warping'                          -> MOUSE_WARPING
37   'force_focus_wrapping'                   -> FORCE_FOCUS_WRAPPING
38   'force_xinerama', 'force-xinerama'       -> FORCE_XINERAMA
39   'workspace_auto_back_and_forth'          -> WORKSPACE_BACK_AND_FORTH
40   'fake_outputs', 'fake-outputs'           -> FAKE_OUTPUTS
41   'force_display_urgency_hint'             -> FORCE_DISPLAY_URGENCY_HINT
42   'focus_on_window_activation'             -> FOCUS_ON_WINDOW_ACTIVATION
43   'show_marks'                             -> SHOW_MARKS
44   'workspace'                              -> WORKSPACE
45   'ipc_socket', 'ipc-socket'               -> IPC_SOCKET
46   'restart_state'                          -> RESTART_STATE
47   'popup_during_fullscreen'                -> POPUP_DURING_FULLSCREEN
48   exectype = 'exec_always', 'exec'         -> EXEC
49   colorclass = 'client.background'
50       -> COLOR_SINGLE
51   colorclass = 'client.focused_inactive', 'client.focused', 'client.unfocused', 'client.urgent', 'client.placeholder'
52       -> COLOR_BORDER
53
54 # We ignore comments and 'set' lines (variables).
55 state IGNORE_LINE:
56   line
57       -> INITIAL
58
59 # floating_minimum_size <width> x <height>
60 state FLOATING_MINIMUM_SIZE_WIDTH:
61   width = number
62       -> FLOATING_MINIMUM_SIZE_X
63
64 state FLOATING_MINIMUM_SIZE_X:
65   'x'
66       -> FLOATING_MINIMUM_SIZE_HEIGHT
67
68 state FLOATING_MINIMUM_SIZE_HEIGHT:
69   height = number
70       -> call cfg_floating_minimum_size(&width, &height)
71
72 # floating_maximum_size <width> x <height>
73 state FLOATING_MAXIMUM_SIZE_WIDTH:
74   width = number
75       -> FLOATING_MAXIMUM_SIZE_X
76
77 state FLOATING_MAXIMUM_SIZE_X:
78   'x'
79       -> FLOATING_MAXIMUM_SIZE_HEIGHT
80
81 state FLOATING_MAXIMUM_SIZE_HEIGHT:
82   height = number
83       -> call cfg_floating_maximum_size(&width, &height)
84
85 # floating_modifier <modifier>
86 state FLOATING_MODIFIER:
87   modifiers = 'Mod1', 'Mod2', 'Mod3', 'Mod4', 'Mod5', 'Shift', 'Control', 'Ctrl'
88       ->
89   '+'
90       ->
91   end
92       -> call cfg_floating_modifier($modifiers)
93
94 # default_orientation <horizontal|vertical|auto>
95 state DEFAULT_ORIENTATION:
96   orientation = 'horizontal', 'vertical', 'auto'
97       -> call cfg_default_orientation($orientation)
98
99 # workspace_layout <default|stacking|tabbed>
100 state WORKSPACE_LAYOUT:
101   layout = 'default', 'stacking', 'stacked', 'tabbed'
102       -> call cfg_workspace_layout($layout)
103
104 # new_window <normal|1pixel|none>
105 # new_float <normal|1pixel|none>
106 state NEW_WINDOW:
107   border = 'normal', 'pixel'
108       -> NEW_WINDOW_PIXELS
109   border = '1pixel', 'none'
110       -> call cfg_new_window($windowtype, $border, -1)
111
112 state NEW_WINDOW_PIXELS:
113   end
114       -> call cfg_new_window($windowtype, $border, 2)
115   width = number
116       -> NEW_WINDOW_PIXELS_PX
117
118 state NEW_WINDOW_PIXELS_PX:
119   'px'
120       ->
121   end
122       -> call cfg_new_window($windowtype, $border, &width)
123
124 # hide_edge_borders <none|vertical|horizontal|both>
125 # also hide_edge_borders <bool> for compatibility
126 state HIDE_EDGE_BORDERS:
127   hide_borders = 'none', 'vertical', 'horizontal', 'both'
128       -> call cfg_hide_edge_borders($hide_borders)
129   hide_borders = '1', 'yes', 'true', 'on', 'enable', 'active'
130       -> call cfg_hide_edge_borders($hide_borders)
131
132 # for_window <criteria> command
133 state FOR_WINDOW:
134   '['
135       -> call cfg_criteria_init(FOR_WINDOW_COMMAND); CRITERIA
136
137 state FOR_WINDOW_COMMAND:
138   command = string
139       -> call cfg_for_window($command)
140
141 # assign <criteria> [→] workspace
142 state ASSIGN:
143   '['
144       -> call cfg_criteria_init(ASSIGN_WORKSPACE); CRITERIA
145
146 state ASSIGN_WORKSPACE:
147   '→'
148       ->
149   workspace = string
150       -> call cfg_assign($workspace)
151
152 # no_focus <criteria>
153 state NO_FOCUS:
154   '['
155       -> call cfg_criteria_init(NO_FOCUS_END); CRITERIA
156
157 state NO_FOCUS_END:
158   end
159       -> call cfg_no_focus()
160
161 # Criteria: Used by for_window and assign.
162 state CRITERIA:
163   ctype = 'class'       -> CRITERION
164   ctype = 'instance'    -> CRITERION
165   ctype = 'window_role' -> CRITERION
166   ctype = 'con_id'      -> CRITERION
167   ctype = 'id'          -> CRITERION
168   ctype = 'window_type' -> CRITERION
169   ctype = 'con_mark'    -> CRITERION
170   ctype = 'title'       -> CRITERION
171   ctype = 'urgent'      -> CRITERION
172   ctype = 'workspace'   -> CRITERION
173   ']'
174       -> call cfg_criteria_pop_state()
175
176 state CRITERION:
177   '=' -> CRITERION_STR
178
179 state CRITERION_STR:
180   cvalue = word
181       -> call cfg_criteria_add($ctype, $cvalue); CRITERIA
182
183 # focus_follows_mouse bool
184 state FOCUS_FOLLOWS_MOUSE:
185   value = word
186       -> call cfg_focus_follows_mouse($value)
187
188 # mouse_warping warping_t
189 state MOUSE_WARPING:
190   value = 'none', 'output'
191       -> call cfg_mouse_warping($value)
192
193 # force_focus_wrapping
194 state FORCE_FOCUS_WRAPPING:
195   value = word
196       -> call cfg_force_focus_wrapping($value)
197
198 # force_xinerama
199 state FORCE_XINERAMA:
200   value = word
201       -> call cfg_force_xinerama($value)
202
203 # workspace_back_and_forth
204 state WORKSPACE_BACK_AND_FORTH:
205   value = word
206       -> call cfg_workspace_back_and_forth($value)
207
208
209 # fake_outputs (for testcases)
210 state FAKE_OUTPUTS:
211   outputs = string
212       -> call cfg_fake_outputs($outputs)
213
214 # force_display_urgency_hint <timeout> ms
215 state FORCE_DISPLAY_URGENCY_HINT:
216   duration_ms = number
217       -> FORCE_DISPLAY_URGENCY_HINT_MS
218
219 # show_marks
220 state SHOW_MARKS:
221   value = word
222       -> call cfg_show_marks($value)
223
224 state FORCE_DISPLAY_URGENCY_HINT_MS:
225   'ms'
226       ->
227   end
228       -> call cfg_force_display_urgency_hint(&duration_ms)
229
230 # focus_on_window_activation <smart|urgent|focus|none>
231 state FOCUS_ON_WINDOW_ACTIVATION:
232   mode = word
233       -> call cfg_focus_on_window_activation($mode)
234
235 # workspace <workspace> output <output>
236 state WORKSPACE:
237   workspace = word
238     -> WORKSPACE_OUTPUT
239
240 state WORKSPACE_OUTPUT:
241   'output'
242       -> WORKSPACE_OUTPUT_STR
243
244 state WORKSPACE_OUTPUT_STR:
245   output = word
246       -> call cfg_workspace($workspace, $output)
247
248 # ipc-socket <path>
249 state IPC_SOCKET:
250   path = string
251       -> call cfg_ipc_socket($path)
252
253 # restart_state <path> (for testcases)
254 state RESTART_STATE:
255   path = string
256       -> call cfg_restart_state($path)
257
258 # popup_during_fullscreen
259 state POPUP_DURING_FULLSCREEN:
260   value = 'ignore', 'leave_fullscreen', 'smart'
261       -> call cfg_popup_during_fullscreen($value)
262
263 # client.background <hexcolor>
264 state COLOR_SINGLE:
265   color = word
266       -> call cfg_color_single($colorclass, $color)
267
268 # colorclass border background text indicator
269 state COLOR_BORDER:
270   border = word
271       -> COLOR_BACKGROUND
272
273 state COLOR_BACKGROUND:
274   background = word
275       -> COLOR_TEXT
276
277 state COLOR_TEXT:
278   text = word
279       -> COLOR_INDICATOR
280
281 state COLOR_INDICATOR:
282   indicator = word
283       -> call cfg_color($colorclass, $border, $background, $text, $indicator)
284   end
285       -> call cfg_color($colorclass, $border, $background, $text, NULL)
286
287 # <exec|exec_always> [--no-startup-id] command
288 state EXEC:
289   no_startup_id = '--no-startup-id'
290       ->
291   command = string
292       -> call cfg_exec($exectype, $no_startup_id, $command)
293
294 # font font
295 state FONT:
296   font = string
297       -> call cfg_font($font)
298
299 # bindsym/bindcode
300 state BINDING:
301   release = '--release'
302       ->
303   border = '--border'
304       ->
305   whole_window = '--whole-window'
306       ->
307   modifiers = 'Mod1', 'Mod2', 'Mod3', 'Mod4', 'Mod5', 'Shift', 'Control', 'Ctrl', 'Mode_switch', 'Group1', 'Group2', 'Group3', 'Group4', '$mod'
308       ->
309   '+'
310       ->
311   key = word
312       -> BINDCOMMAND
313
314 state BINDCOMMAND:
315   release = '--release'
316       ->
317   border = '--border'
318       ->
319   whole_window = '--whole-window'
320       ->
321   command = string
322       -> call cfg_binding($bindtype, $modifiers, $key, $release, $border, $whole_window, $command)
323
324 ################################################################################
325 # Mode configuration
326 ################################################################################
327
328 state MODENAME:
329   pango_markup = '--pango_markup'
330       ->
331   modename = word
332       -> call cfg_enter_mode($pango_markup, $modename); MODEBRACE
333
334 state MODEBRACE:
335   end
336       ->
337   '{'
338       -> MODE
339
340 state MODE:
341   end ->
342   error ->
343   '#' -> MODE_IGNORE_LINE
344   'set' -> MODE_IGNORE_LINE
345   bindtype = 'bindsym', 'bindcode', 'bind'
346       -> MODE_BINDING
347   '}'
348       -> INITIAL
349
350 # We ignore comments and 'set' lines (variables).
351 state MODE_IGNORE_LINE:
352   line
353       -> MODE
354
355 state MODE_BINDING:
356   release = '--release'
357       ->
358   border = '--border'
359       ->
360   whole_window = '--whole-window'
361       ->
362   modifiers = 'Mod1', 'Mod2', 'Mod3', 'Mod4', 'Mod5', 'Shift', 'Control', 'Ctrl', 'Mode_switch', 'Group1', 'Group2', 'Group3', 'Group4', '$mod'
363       ->
364   '+'
365       ->
366   key = word
367       -> MODE_BINDCOMMAND
368
369 state MODE_BINDCOMMAND:
370   release = '--release'
371       ->
372   border = '--border'
373       ->
374   whole_window = '--whole-window'
375       ->
376   command = string
377       -> call cfg_mode_binding($bindtype, $modifiers, $key, $release, $border, $whole_window, $command); MODE
378
379 ################################################################################
380 # Bar configuration (i3bar)
381 ################################################################################
382
383 state BARBRACE:
384   end
385       ->
386   '{'
387       -> call cfg_bar_start(); BAR
388
389 state BAR:
390   end ->
391   error ->
392   '#' -> BAR_IGNORE_LINE
393   'set' -> BAR_IGNORE_LINE
394   'i3bar_command'          -> BAR_BAR_COMMAND
395   'status_command'         -> BAR_STATUS_COMMAND
396   'socket_path'            -> BAR_SOCKET_PATH
397   'mode'                   -> BAR_MODE
398   'hidden_state'           -> BAR_HIDDEN_STATE
399   'id'                     -> BAR_ID
400   'modifier'               -> BAR_MODIFIER
401   'wheel_up_cmd'           -> BAR_WHEEL_UP_CMD
402   'wheel_down_cmd'         -> BAR_WHEEL_DOWN_CMD
403   'bindsym'                -> BAR_BINDSYM
404   'position'               -> BAR_POSITION
405   'output'                 -> BAR_OUTPUT
406   'tray_output'            -> BAR_TRAY_OUTPUT
407   'tray_padding'           -> BAR_TRAY_PADDING
408   'font'                   -> BAR_FONT
409   'separator_symbol'       -> BAR_SEPARATOR_SYMBOL
410   'binding_mode_indicator' -> BAR_BINDING_MODE_INDICATOR
411   'workspace_buttons'      -> BAR_WORKSPACE_BUTTONS
412   'strip_workspace_numbers' -> BAR_STRIP_WORKSPACE_NUMBERS
413   'verbose'                -> BAR_VERBOSE
414   'colors'                 -> BAR_COLORS_BRACE
415   '}'
416       -> call cfg_bar_finish(); INITIAL
417
418 # We ignore comments and 'set' lines (variables).
419 state BAR_IGNORE_LINE:
420   line
421       -> BAR
422
423 state BAR_BAR_COMMAND:
424   command = string
425       -> call cfg_bar_i3bar_command($command); BAR
426
427 state BAR_STATUS_COMMAND:
428   command = string
429       -> call cfg_bar_status_command($command); BAR
430
431 state BAR_SOCKET_PATH:
432   path = string
433       -> call cfg_bar_socket_path($path); BAR
434
435 state BAR_MODE:
436   mode = 'dock', 'hide', 'invisible'
437       -> call cfg_bar_mode($mode); BAR
438
439 state BAR_HIDDEN_STATE:
440   hidden_state = 'hide', 'show'
441       -> call cfg_bar_hidden_state($hidden_state); BAR
442
443 state BAR_ID:
444   bar_id = word
445       -> call cfg_bar_id($bar_id); BAR
446
447 state BAR_MODIFIER:
448   modifier = 'Mod1', 'Mod2', 'Mod3', 'Mod4', 'Mod5', 'Control', 'Ctrl', 'Shift'
449       -> call cfg_bar_modifier($modifier); BAR
450
451 state BAR_WHEEL_UP_CMD:
452   command = string
453       -> call cfg_bar_wheel_up_cmd($command); BAR
454
455 state BAR_WHEEL_DOWN_CMD:
456   command = string
457       -> call cfg_bar_wheel_down_cmd($command); BAR
458
459 state BAR_BINDSYM:
460   button = word
461       -> BAR_BINDSYM_COMMAND
462
463 state BAR_BINDSYM_COMMAND:
464   command = string
465       -> call cfg_bar_bindsym($button, $command); BAR
466
467 state BAR_POSITION:
468   position = 'top', 'bottom'
469       -> call cfg_bar_position($position); BAR
470
471 state BAR_OUTPUT:
472   output = string
473       -> call cfg_bar_output($output); BAR
474
475 state BAR_TRAY_OUTPUT:
476   output = word
477       -> call cfg_bar_tray_output($output); BAR
478
479 state BAR_TRAY_PADDING:
480   padding_px = number
481       -> BAR_TRAY_PADDING_PX
482
483 state BAR_TRAY_PADDING_PX:
484   'px'
485       ->
486   end
487       -> call cfg_bar_tray_padding(&padding_px); BAR
488
489 state BAR_FONT:
490   font = string
491       -> call cfg_bar_font($font); BAR
492
493 state BAR_SEPARATOR_SYMBOL:
494   separator = string
495       -> call cfg_bar_separator_symbol($separator); BAR
496
497 state BAR_BINDING_MODE_INDICATOR:
498   value = word
499       -> call cfg_bar_binding_mode_indicator($value); BAR
500
501 state BAR_WORKSPACE_BUTTONS:
502   value = word
503       -> call cfg_bar_workspace_buttons($value); BAR
504
505 state BAR_STRIP_WORKSPACE_NUMBERS:
506   value = word
507       -> call cfg_bar_strip_workspace_numbers($value); BAR
508
509 state BAR_VERBOSE:
510   value = word
511       -> call cfg_bar_verbose($value); BAR
512
513 state BAR_COLORS_BRACE:
514   end
515       ->
516   '{'
517       -> BAR_COLORS
518
519 state BAR_COLORS:
520   end ->
521   '#' -> BAR_COLORS_IGNORE_LINE
522   'set' -> BAR_COLORS_IGNORE_LINE
523   colorclass = 'background', 'statusline', 'separator', 'focused_background', 'focused_statusline', 'focused_separator'
524       -> BAR_COLORS_SINGLE
525   colorclass = 'focused_workspace', 'active_workspace', 'inactive_workspace', 'urgent_workspace', 'binding_mode'
526       -> BAR_COLORS_BORDER
527   '}'
528       -> BAR
529
530 # We ignore comments and 'set' lines (variables).
531 state BAR_COLORS_IGNORE_LINE:
532   line
533       -> BAR_COLORS
534
535 state BAR_COLORS_SINGLE:
536   color = word
537       -> call cfg_bar_color_single($colorclass, $color); BAR_COLORS
538
539 state BAR_COLORS_BORDER:
540   border = word
541       -> BAR_COLORS_BACKGROUND
542
543 state BAR_COLORS_BACKGROUND:
544   background = word
545       -> BAR_COLORS_TEXT
546
547 state BAR_COLORS_TEXT:
548   end
549       -> call cfg_bar_color($colorclass, $border, $background, NULL); BAR_COLORS
550   text = word
551       -> call cfg_bar_color($colorclass, $border, $background, $text); BAR_COLORS