]> git.sur5r.net Git - i3/i3/blob - parser-specs/config.spec
d27e0792127a6f78b863995941994cf66523439b
[i3/i3] / parser-specs / config.spec
1 # vim:ts=2:sw=2:expandtab
2 #
3 # i3 - an improved dynamic tiling window manager
4 # © 2009-2012 Michael Stapelberg and contributors (see also: LICENSE)
5 #
6 # parser-specs/config.spec: Specification file for generate-command-parser.pl
7 # which will generate the appropriate header files for our C parser.
8 #
9 # Use :source highlighting.vim in vim to get syntax highlighting
10 # for this file.
11
12 # TODO: should we implement an include statement for the criteria part so we DRY?
13
14 state INITIAL:
15   # We have an end token here for all the commands which just call some
16   # function without using an explicit 'end' token.
17   end ->
18   error ->
19   '#'                                      -> IGNORE_LINE
20   'set'                                    -> IGNORE_LINE
21   bindtype = 'bindsym', 'bindcode', 'bind' -> BINDING
22   'bar'                                    -> BARBRACE
23   'font'                                   -> FONT
24   'mode'                                   -> MODENAME
25   'floating_minimum_size'                  -> FLOATING_MINIMUM_SIZE_WIDTH
26   'floating_maximum_size'                  -> FLOATING_MAXIMUM_SIZE_WIDTH
27   'floating_modifier'                      -> FLOATING_MODIFIER
28   'default_orientation'                    -> DEFAULT_ORIENTATION
29   'workspace_layout'                       -> WORKSPACE_LAYOUT
30   windowtype = 'new_window', 'new_float'   -> NEW_WINDOW
31   'hide_edge_borders'                      -> HIDE_EDGE_BORDERS
32   'for_window'                             -> FOR_WINDOW
33   'assign'                                 -> ASSIGN
34   'no_focus'                               -> NO_FOCUS
35   'focus_follows_mouse'                    -> FOCUS_FOLLOWS_MOUSE
36   'mouse_warping'                          -> MOUSE_WARPING
37   'force_focus_wrapping'                   -> FORCE_FOCUS_WRAPPING
38   'force_xinerama', 'force-xinerama'       -> FORCE_XINERAMA
39   'workspace_auto_back_and_forth'          -> WORKSPACE_BACK_AND_FORTH
40   'fake_outputs', 'fake-outputs'           -> FAKE_OUTPUTS
41   'force_display_urgency_hint'             -> FORCE_DISPLAY_URGENCY_HINT
42   'focus_on_window_activation'             -> FOCUS_ON_WINDOW_ACTIVATION
43   'show_marks'                             -> SHOW_MARKS
44   'workspace'                              -> WORKSPACE
45   'ipc_socket', 'ipc-socket'               -> IPC_SOCKET
46   'restart_state'                          -> RESTART_STATE
47   'popup_during_fullscreen'                -> POPUP_DURING_FULLSCREEN
48   exectype = 'exec_always', 'exec'         -> EXEC
49   colorclass = 'client.background'
50       -> COLOR_SINGLE
51   colorclass = 'client.focused_inactive', 'client.focused', 'client.unfocused', 'client.urgent', 'client.placeholder'
52       -> COLOR_BORDER
53
54 # We ignore comments and 'set' lines (variables).
55 state IGNORE_LINE:
56   line
57       -> INITIAL
58
59 # floating_minimum_size <width> x <height>
60 state FLOATING_MINIMUM_SIZE_WIDTH:
61   width = number
62       -> FLOATING_MINIMUM_SIZE_X
63
64 state FLOATING_MINIMUM_SIZE_X:
65   'x'
66       -> FLOATING_MINIMUM_SIZE_HEIGHT
67
68 state FLOATING_MINIMUM_SIZE_HEIGHT:
69   height = number
70       -> call cfg_floating_minimum_size(&width, &height)
71
72 # floating_maximum_size <width> x <height>
73 state FLOATING_MAXIMUM_SIZE_WIDTH:
74   width = number
75       -> FLOATING_MAXIMUM_SIZE_X
76
77 state FLOATING_MAXIMUM_SIZE_X:
78   'x'
79       -> FLOATING_MAXIMUM_SIZE_HEIGHT
80
81 state FLOATING_MAXIMUM_SIZE_HEIGHT:
82   height = number
83       -> call cfg_floating_maximum_size(&width, &height)
84
85 # floating_modifier <modifier>
86 state FLOATING_MODIFIER:
87   modifiers = 'Mod1', 'Mod2', 'Mod3', 'Mod4', 'Mod5', 'Shift', 'Control', 'Ctrl'
88       ->
89   '+'
90       ->
91   end
92       -> call cfg_floating_modifier($modifiers)
93
94 # default_orientation <horizontal|vertical|auto>
95 state DEFAULT_ORIENTATION:
96   orientation = 'horizontal', 'vertical', 'auto'
97       -> call cfg_default_orientation($orientation)
98
99 # workspace_layout <default|stacking|tabbed>
100 state WORKSPACE_LAYOUT:
101   layout = 'default', 'stacking', 'stacked', 'tabbed'
102       -> call cfg_workspace_layout($layout)
103
104 # new_window <normal|1pixel|none>
105 # new_float <normal|1pixel|none>
106 # TODO: new_float is not in the userguide yet
107 # TODO: pixel is not in the userguide yet
108 state NEW_WINDOW:
109   border = 'normal', 'pixel'
110       -> NEW_WINDOW_PIXELS
111   border = '1pixel', 'none'
112       -> call cfg_new_window($windowtype, $border, -1)
113
114 state NEW_WINDOW_PIXELS:
115   end
116       -> call cfg_new_window($windowtype, $border, 2)
117   width = number
118       -> NEW_WINDOW_PIXELS_PX
119
120 state NEW_WINDOW_PIXELS_PX:
121   'px'
122       ->
123   end
124       -> call cfg_new_window($windowtype, $border, &width)
125
126 # hide_edge_borders <none|vertical|horizontal|both>
127 # also hide_edge_borders <bool> for compatibility
128 state HIDE_EDGE_BORDERS:
129   hide_borders = 'none', 'vertical', 'horizontal', 'both'
130       -> call cfg_hide_edge_borders($hide_borders)
131   hide_borders = '1', 'yes', 'true', 'on', 'enable', 'active'
132       -> call cfg_hide_edge_borders($hide_borders)
133
134 # for_window <criteria> command
135 state FOR_WINDOW:
136   '['
137       -> call cfg_criteria_init(FOR_WINDOW_COMMAND); CRITERIA
138
139 state FOR_WINDOW_COMMAND:
140   command = string
141       -> call cfg_for_window($command)
142
143 # assign <criteria> [→] workspace
144 state ASSIGN:
145   '['
146       -> call cfg_criteria_init(ASSIGN_WORKSPACE); CRITERIA
147
148 state ASSIGN_WORKSPACE:
149   '→'
150       ->
151   workspace = string
152       -> call cfg_assign($workspace)
153
154 # no_focus <criteria>
155 state NO_FOCUS:
156   '['
157       -> call cfg_criteria_init(NO_FOCUS_END); CRITERIA
158
159 state NO_FOCUS_END:
160   end
161       -> call cfg_no_focus()
162
163 # Criteria: Used by for_window and assign.
164 state CRITERIA:
165   ctype = 'class'       -> CRITERION
166   ctype = 'instance'    -> CRITERION
167   ctype = 'window_role' -> CRITERION
168   ctype = 'con_id'      -> CRITERION
169   ctype = 'id'          -> CRITERION
170   ctype = 'con_mark'    -> CRITERION
171   ctype = 'title'       -> CRITERION
172   ctype = 'urgent'      -> CRITERION
173   ']'
174       -> call cfg_criteria_pop_state()
175
176 state CRITERION:
177   '=' -> CRITERION_STR
178
179 state CRITERION_STR:
180   cvalue = word
181       -> call cfg_criteria_add($ctype, $cvalue); CRITERIA
182
183 # focus_follows_mouse bool
184 state FOCUS_FOLLOWS_MOUSE:
185   value = word
186       -> call cfg_focus_follows_mouse($value)
187
188 # mouse_warping warping_t
189 state MOUSE_WARPING:
190   value = 'none', 'output'
191       -> call cfg_mouse_warping($value)
192
193 # force_focus_wrapping
194 state FORCE_FOCUS_WRAPPING:
195   value = word
196       -> call cfg_force_focus_wrapping($value)
197
198 # force_xinerama
199 state FORCE_XINERAMA:
200   value = word
201       -> call cfg_force_xinerama($value)
202
203 # workspace_back_and_forth
204 state WORKSPACE_BACK_AND_FORTH:
205   value = word
206       -> call cfg_workspace_back_and_forth($value)
207
208
209 # fake_outputs (for testcases)
210 state FAKE_OUTPUTS:
211   outputs = string
212       -> call cfg_fake_outputs($outputs)
213
214 # force_display_urgency_hint <timeout> ms
215 state FORCE_DISPLAY_URGENCY_HINT:
216   duration_ms = number
217       -> FORCE_DISPLAY_URGENCY_HINT_MS
218
219 # show_marks
220 state SHOW_MARKS:
221   value = word
222       -> call cfg_show_marks($value)
223
224 state FORCE_DISPLAY_URGENCY_HINT_MS:
225   'ms'
226       ->
227   end
228       -> call cfg_force_display_urgency_hint(&duration_ms)
229
230 # focus_on_window_activation <smart|urgent|focus|none>
231 state FOCUS_ON_WINDOW_ACTIVATION:
232   mode = word
233       -> call cfg_focus_on_window_activation($mode)
234
235 # workspace <workspace> output <output>
236 state WORKSPACE:
237   workspace = word
238     -> WORKSPACE_OUTPUT
239
240 state WORKSPACE_OUTPUT:
241   'output'
242       -> WORKSPACE_OUTPUT_STR
243
244 state WORKSPACE_OUTPUT_STR:
245   output = word
246       -> call cfg_workspace($workspace, $output)
247
248 # ipc-socket <path>
249 state IPC_SOCKET:
250   path = string
251       -> call cfg_ipc_socket($path)
252
253 # restart_state <path> (for testcases)
254 state RESTART_STATE:
255   path = string
256       -> call cfg_restart_state($path)
257
258 # popup_during_fullscreen
259 state POPUP_DURING_FULLSCREEN:
260   value = 'ignore', 'leave_fullscreen', 'smart'
261       -> call cfg_popup_during_fullscreen($value)
262
263 # client.background <hexcolor>
264 state COLOR_SINGLE:
265   color = word
266       -> call cfg_color_single($colorclass, $color)
267
268 # colorclass border background text indicator
269 state COLOR_BORDER:
270   border = word
271       -> COLOR_BACKGROUND
272
273 state COLOR_BACKGROUND:
274   background = word
275       -> COLOR_TEXT
276
277 state COLOR_TEXT:
278   text = word
279       -> COLOR_INDICATOR
280
281 state COLOR_INDICATOR:
282   indicator = word
283       -> call cfg_color($colorclass, $border, $background, $text, $indicator)
284   end
285       -> call cfg_color($colorclass, $border, $background, $text, NULL)
286
287 # <exec|exec_always> [--no-startup-id] command
288 state EXEC:
289   no_startup_id = '--no-startup-id'
290       ->
291   command = string
292       -> call cfg_exec($exectype, $no_startup_id, $command)
293
294 # font font
295 state FONT:
296   font = string
297       -> call cfg_font($font)
298
299 # bindsym/bindcode
300 state BINDING:
301   release = '--release'
302       ->
303   whole_window = '--whole-window'
304       ->
305   modifiers = 'Mod1', 'Mod2', 'Mod3', 'Mod4', 'Mod5', 'Shift', 'Control', 'Ctrl', 'Mode_switch', '$mod'
306       ->
307   '+'
308       ->
309   key = word
310       -> BINDCOMMAND
311
312 state BINDCOMMAND:
313   release = '--release'
314       ->
315   whole_window = '--whole-window'
316       ->
317   command = string
318       -> call cfg_binding($bindtype, $modifiers, $key, $release, $whole_window, $command)
319
320 ################################################################################
321 # Mode configuration
322 ################################################################################
323
324 state MODENAME:
325   modename = word
326       -> call cfg_enter_mode($modename); MODEBRACE
327
328 state MODEBRACE:
329   end
330       ->
331   '{'
332       -> MODE
333
334 state MODE:
335   end ->
336   error ->
337   '#' -> MODE_IGNORE_LINE
338   'set' -> MODE_IGNORE_LINE
339   bindtype = 'bindsym', 'bindcode', 'bind'
340       -> MODE_BINDING
341   '}'
342       -> INITIAL
343
344 # We ignore comments and 'set' lines (variables).
345 state MODE_IGNORE_LINE:
346   line
347       -> MODE
348
349 state MODE_BINDING:
350   release = '--release'
351       ->
352   whole_window = '--whole-window'
353       ->
354   modifiers = 'Mod1', 'Mod2', 'Mod3', 'Mod4', 'Mod5', 'Shift', 'Control', 'Ctrl', 'Mode_switch', '$mod'
355       ->
356   '+'
357       ->
358   key = word
359       -> MODE_BINDCOMMAND
360
361 state MODE_BINDCOMMAND:
362   release = '--release'
363       ->
364   whole_window = '--whole-window'
365       ->
366   command = string
367       -> call cfg_mode_binding($bindtype, $modifiers, $key, $release, $whole_window, $command); MODE
368
369 ################################################################################
370 # Bar configuration (i3bar)
371 ################################################################################
372
373 state BARBRACE:
374   end
375       ->
376   '{'
377       -> BAR
378
379 state BAR:
380   end ->
381   error ->
382   '#' -> BAR_IGNORE_LINE
383   'set' -> BAR_IGNORE_LINE
384   'i3bar_command'          -> BAR_BAR_COMMAND
385   'status_command'         -> BAR_STATUS_COMMAND
386   'socket_path'            -> BAR_SOCKET_PATH
387   'mode'                   -> BAR_MODE
388   'hidden_state'           -> BAR_HIDDEN_STATE
389   'id'                     -> BAR_ID
390   'modifier'               -> BAR_MODIFIER
391   'wheel_up_cmd'           -> BAR_WHEEL_UP_CMD
392   'wheel_down_cmd'         -> BAR_WHEEL_DOWN_CMD
393   'position'               -> BAR_POSITION
394   'output'                 -> BAR_OUTPUT
395   'tray_output'            -> BAR_TRAY_OUTPUT
396   'font'                   -> BAR_FONT
397   'separator_symbol'       -> BAR_SEPARATOR_SYMBOL
398   'binding_mode_indicator' -> BAR_BINDING_MODE_INDICATOR
399   'workspace_buttons'      -> BAR_WORKSPACE_BUTTONS
400   'strip_workspace_numbers' -> BAR_STRIP_WORKSPACE_NUMBERS
401   'verbose'                -> BAR_VERBOSE
402   'colors'                 -> BAR_COLORS_BRACE
403   '}'
404       -> call cfg_bar_finish(); INITIAL
405
406 # We ignore comments and 'set' lines (variables).
407 state BAR_IGNORE_LINE:
408   line
409       -> BAR
410
411 state BAR_BAR_COMMAND:
412   command = string
413       -> call cfg_bar_i3bar_command($command); BAR
414
415 state BAR_STATUS_COMMAND:
416   command = string
417       -> call cfg_bar_status_command($command); BAR
418
419 state BAR_SOCKET_PATH:
420   path = string
421       -> call cfg_bar_socket_path($path); BAR
422
423 state BAR_MODE:
424   mode = 'dock', 'hide', 'invisible'
425       -> call cfg_bar_mode($mode); BAR
426
427 state BAR_HIDDEN_STATE:
428   hidden_state = 'hide', 'show'
429       -> call cfg_bar_hidden_state($hidden_state); BAR
430
431 state BAR_ID:
432   bar_id = word
433       -> call cfg_bar_id($bar_id); BAR
434
435 state BAR_MODIFIER:
436   modifier = 'Mod1', 'Mod2', 'Mod3', 'Mod4', 'Mod5', 'Control', 'Ctrl', 'Shift'
437       -> call cfg_bar_modifier($modifier); BAR
438
439 state BAR_WHEEL_UP_CMD:
440   command = string
441       -> call cfg_bar_wheel_up_cmd($command); BAR
442
443 state BAR_WHEEL_DOWN_CMD:
444   command = string
445       -> call cfg_bar_wheel_down_cmd($command); BAR
446
447 state BAR_POSITION:
448   position = 'top', 'bottom'
449       -> call cfg_bar_position($position); BAR
450
451 state BAR_OUTPUT:
452   output = string
453       -> call cfg_bar_output($output); BAR
454
455 state BAR_TRAY_OUTPUT:
456   output = word
457       -> call cfg_bar_tray_output($output); BAR
458
459 state BAR_FONT:
460   font = string
461       -> call cfg_bar_font($font); BAR
462
463 state BAR_SEPARATOR_SYMBOL:
464   separator = string
465       -> call cfg_bar_separator_symbol($separator); BAR
466
467 state BAR_BINDING_MODE_INDICATOR:
468   value = word
469       -> call cfg_bar_binding_mode_indicator($value); BAR
470
471 state BAR_WORKSPACE_BUTTONS:
472   value = word
473       -> call cfg_bar_workspace_buttons($value); BAR
474
475 state BAR_STRIP_WORKSPACE_NUMBERS:
476   value = word
477       -> call cfg_bar_strip_workspace_numbers($value); BAR
478
479 state BAR_VERBOSE:
480   value = word
481       -> call cfg_bar_verbose($value); BAR
482
483 state BAR_COLORS_BRACE:
484   end
485       ->
486   '{'
487       -> BAR_COLORS
488
489 state BAR_COLORS:
490   end ->
491   '#' -> BAR_COLORS_IGNORE_LINE
492   'set' -> BAR_COLORS_IGNORE_LINE
493   colorclass = 'background', 'statusline', 'separator'
494       -> BAR_COLORS_SINGLE
495   colorclass = 'focused_workspace', 'active_workspace', 'inactive_workspace', 'urgent_workspace'
496       -> BAR_COLORS_BORDER
497   '}'
498       -> BAR
499
500 # We ignore comments and 'set' lines (variables).
501 state BAR_COLORS_IGNORE_LINE:
502   line
503       -> BAR_COLORS
504
505 state BAR_COLORS_SINGLE:
506   color = word
507       -> call cfg_bar_color_single($colorclass, $color); BAR_COLORS
508
509 state BAR_COLORS_BORDER:
510   border = word
511       -> BAR_COLORS_BACKGROUND
512
513 state BAR_COLORS_BACKGROUND:
514   background = word
515       -> BAR_COLORS_TEXT
516
517 state BAR_COLORS_TEXT:
518   end
519       -> call cfg_bar_color($colorclass, $border, $background, NULL); BAR_COLORS
520   text = word
521       -> call cfg_bar_color($colorclass, $border, $background, $text); BAR_COLORS