]> git.sur5r.net Git - kconfig-frontends/blobdiff - frontends/Makefile.am
frontends: add the meta-frontend kconfig
[kconfig-frontends] / frontends / Makefile.am
index 0badbc8c6d95a4b43c2dedd8d235a33955465e75..6e77564dea9ce700ae89618e637ba9467b9b4d03 100644 (file)
@@ -1,3 +1,6 @@
+if COND_kconfig
+    MAYBE_kconfig = kconfig
+endif
 if COND_conf
     MAYBE_conf = conf
 endif
@@ -14,3 +17,12 @@ if COND_qconf
     MAYBE_qconf = qconf
 endif
 SUBDIRS = $(MAYBE_conf) $(MAYBE_mconf) $(MAYBE_nconf) $(MAYBE_gconf) $(MAYBE_qconf)
+
+EXTRA_DIST = kconfig.in
+
+bin_SCRIPTS = $(MAYBE_kconfig)
+
+kconfig: kconfig.in
+       $(AM_V_GEN)$(SED) -e 's/@KCFG_LIST@/$(kcfg_list)/g'      \
+                         $< >$@
+       @chmod +x $@