]> git.sur5r.net Git - kconfig-frontends/blobdiff - libs/parser/Makefile.am
parser: build a shared library
[kconfig-frontends] / libs / parser / Makefile.am
index 5f0d352ce36f3a378f9c032c5dd68d676496a3fd..40fe4b87d7a3a694c15270a5aa9871f5d51438f7 100644 (file)
@@ -1,13 +1,14 @@
 SUFFIXES = .gperf
 
-noinst_LIBRARIES = libkconfigparser.a
-
-libkconfigparser_a_SOURCES = yconf.y
-dist_EXTRA_libkconfigparser_a_SOURCES =   \
+lib_LTLIBRARIES = libkconfigparser.la
+libkconfigparser_la_SOURCES = yconf.y
+dist_EXTRA_libkconfigparser_la_SOURCES =  \
     hconf.gperf lconf.l                   \
     confdata.c menu.c symbol.c util.c     \
     expr.c expr.h lkc.h lkc_proto.h
 
+include_HEADERS = expr.h lkc.h lkc_proto.h
+
 BUILT_SOURCES = hconf.c lconf.c
 
 # Can't use libkconfigparser_a_CPPFLAGS, as it breaks dependencies