]> git.sur5r.net Git - kconfig-frontends/blobdiff - libs/parser/Makefile.am
libs/parser: remove legacy, stray comment
[kconfig-frontends] / libs / parser / Makefile.am
index 482beda54abd8a1f6b6eec69ef31cf7fa124b918..ad6e5aa8b60aeba283534500824899ea616b698a 100644 (file)
@@ -7,9 +7,11 @@ dist_EXTRA_libkconfig_parser_la_SOURCES = \
     confdata.c menu.c symbol.c util.c     \
     expr.c expr.h lkc.h lkc_proto.h
 libkconfig_parser_la_CPPFLAGS = -DROOTMENU="\"$(root_menu)\""   \
-                                -DCONFIG_=\"$(config_prefix)\"
+                                -DCONFIG_=\"$(config_prefix)\"  \
+                                $(intl_CPPFLAGS)
 libkconfig_parser_la_CFLAGS = $(AM_CFLAGS) $(kf_CFLAGS)
-libkconfig_parser_la_LDFLAGS = -release $(KCONFIGPARSER_LIB_VERSION)
+libkconfig_parser_la_LDFLAGS = -release $(KCONFIGPARSER_LIB_VERSION) -no-undefined
+libkconfig_parser_la_LIBADD = $(intl_LIBS)
 
 kconfig_includedir = $(includedir)/kconfig
 kconfig_include_HEADERS = lkc.h expr.h lkc_proto.h
@@ -18,11 +20,12 @@ BUILT_SOURCES = hconf.c lconf.c
 CLEANFILES = hconf.c lconf.c yconf.c
 EXTRA_DIST = yconf.y.patch
 
-# Can't use libkconfig_parser_a_CPPFLAGS, as it breaks dependencies
-yconf.o: CPPFLAGS+=$(GETTEXT)
+AM_V_GPERF = $(AM_V_GPERF_$(V))
+AM_V_GPERF_ = $(AM_V_GPERF_$(AM_DEFAULT_VERBOSITY))
+AM_V_GPERF_0 = @echo "  GPERF " $@;
 
 .gperf.c:
-       $(GPERF) -t --output-file $@ -a -C -E -g -k 1,3,$$ -p -t $<
+       $(AM_V_GPERF)$(GPERF) -t --output-file $@ -a -C -E -g -k 1,3,$$ -p -t $<
 
 # The following rule produces a warning:
 #   libs/parser/Makefile.am:41: user target `.l.c' defined here...
@@ -40,4 +43,4 @@ yconf.o: CPPFLAGS+=$(GETTEXT)
 # also renamed, but automake does not now that, and make would fail
 # because it would think no file was generated.
 .l.c:
-       $(LEXCOMPILE) -o$@ $<
+       $(AM_V_LEX)$(LEXCOMPILE) -o$@ $<