]> git.sur5r.net Git - kconfig-frontends/blobdiff - libs/parser/Makefile.am
buildsystem: don't use recursive make for frontends
[kconfig-frontends] / libs / parser / Makefile.am
index 2ef195cc96ecf93fe1cb651610ce807f3186d64f..d284e6a5a24c54b7bab21eaf848a1ef2499394a6 100644 (file)
@@ -1,28 +1,34 @@
 SUFFIXES = .gperf
 
-lib_LTLIBRARIES = libkconfigparser.la
-libkconfigparser_la_SOURCES = yconf.y
-dist_EXTRA_libkconfigparser_la_SOURCES =  \
+lib_LTLIBRARIES = libkconfig-parser.la
+libkconfig_parser_la_SOURCES = yconf.y
+dist_EXTRA_libkconfig_parser_la_SOURCES = \
     hconf.gperf lconf.l                   \
     confdata.c menu.c symbol.c util.c     \
     expr.c expr.h lkc.h lkc_proto.h
-libkconfigparser_la_CPPFLAGS = -DROOTMENU="\"$(root_menu)\""    \
-                               -DCONFIG_=\"$(config_prefix)\"
-libkconfigparser_la_LDFLAGS = -release $(KCONFIGPARSER_LIB_VERSION)
+libkconfig_parser_la_CPPFLAGS = -DROOTMENU="\"$(root_menu)\""   \
+                                -DCONFIG_=\"$(config_prefix)\"  \
+                                $(intl_CPPFLAGS)
+libkconfig_parser_la_CFLAGS = $(AM_CFLAGS) $(kf_CFLAGS)
+libkconfig_parser_la_LDFLAGS = -release $(KCONFIGPARSER_LIB_VERSION) -no-undefined
+libkconfig_parser_la_LIBADD = $(intl_LIBS)
 
 kconfig_includedir = $(includedir)/kconfig
-kconfig_include_HEADERS = lkc.h expr.h lkc_proto.h
+kconfig_include_HEADERS = list.h lkc.h expr.h lkc_proto.h
 
 BUILT_SOURCES = hconf.c lconf.c
+CLEANFILES = hconf.c lconf.c yconf.c
+EXTRA_DIST = yconf.y.patch
 
-# Can't use libkconfigparser_a_CPPFLAGS, as it breaks dependencies
-yconf.o: CPPFLAGS+=$(GETTEXT)
+AM_V_GPERF = $(AM_V_GPERF_$(V))
+AM_V_GPERF_ = $(AM_V_GPERF_$(AM_DEFAULT_VERBOSITY))
+AM_V_GPERF_0 = @echo "  GPERF   " $@;
 
 .gperf.c:
-       $(GPERF) -t --output-file $@ -a -C -E -g -k 1,3,$$ -p -t $<
+       $(AM_V_GPERF)$(GPERF) -t --output-file $@ -a -C -E -g -k 1,3,$$ -p -t $<
 
 # The following rule produces a warning:
-#   parser/Makefile.am:31: user target `.l.c' defined here...
+#   libs/parser/Makefile.am:41: user target `.l.c' defined here...
 #      /usr/share/automake-1.11/am/lex.am: ... overrides Automake target
 #      `.l.c' defined here
 #
@@ -37,4 +43,4 @@ yconf.o: CPPFLAGS+=$(GETTEXT)
 # also renamed, but automake does not now that, and make would fail
 # because it would think no file was generated.
 .l.c:
-       $(LEXCOMPILE) -o$@ $<
+       $(AM_V_LEX)$(LEXCOMPILE) -o$@ $<