]> git.sur5r.net Git - openocd/blobdiff - src/flash/nor/Makefile.am
max32xxx: Support for MAX32XXX devices.
[openocd] / src / flash / nor / Makefile.am
index 4dac110c4245aaacf5d8c957fc6063a1823494fd..3839d0a8dd9cccc125d007963ddf3941d613bcc5 100644 (file)
@@ -18,6 +18,9 @@ NOR_DRIVERS = \
        %D%/ath79.c \
        %D%/atsamv.c \
        %D%/avrf.c \
+       %D%/bluenrg-x.c \
+       %D%/cc3220sf.c \
+       %D%/cc26xx.c \
        %D%/cfi.c \
        %D%/dsp5680xx_flash.c \
        %D%/efm32.c \
@@ -32,7 +35,9 @@ NOR_DRIVERS = \
        %D%/lpc288x.c \
        %D%/lpc2900.c \
        %D%/lpcspifi.c \
+       %D%/max32xxx.c \
        %D%/mdr.c \
+       %D%/msp432.c \
        %D%/mrvlqspi.c \
        %D%/niietcm4.c \
        %D%/non_cfi.c \
@@ -41,6 +46,8 @@ NOR_DRIVERS = \
        %D%/ocl.c \
        %D%/pic32mx.c \
        %D%/psoc4.c \
+       %D%/psoc5lp.c \
+       %D%/psoc6.c \
        %D%/sim3x.c \
        %D%/spi.c \
        %D%/stmsmi.c \
@@ -49,19 +56,24 @@ NOR_DRIVERS = \
        %D%/stm32f2x.c \
        %D%/stm32lx.c \
        %D%/stm32l4x.c \
+       %D%/stm32h7x.c \
        %D%/str7x.c \
        %D%/str9x.c \
        %D%/str9xpec.c \
        %D%/tms470.c \
        %D%/virtual.c \
+       %D%/xcf.c \
        %D%/xmc1xxx.c \
        %D%/xmc4xxx.c
 
 NORHEADERS = \
        %D%/core.h \
+       %D%/cc3220sf.h \
+       %D%/cc26xx.h \
        %D%/cfi.h \
        %D%/driver.h \
        %D%/imp.h \
        %D%/non_cfi.h \
        %D%/ocl.h \
-       %D%/spi.h
+       %D%/spi.h \
+       %D%/msp432.h