]> git.sur5r.net Git - openocd/blobdiff - src/flash/nor/Makefile.am
max32xxx: Support for MAX32XXX devices.
[openocd] / src / flash / nor / Makefile.am
index 67a5e558bf40da36879362de059dc4fb34555cb5..3839d0a8dd9cccc125d007963ddf3941d613bcc5 100644 (file)
@@ -1,49 +1,79 @@
-AM_CPPFLAGS = -I$(top_srcdir)/src
-
-noinst_LTLIBRARIES = libocdflashnor.la
-libocdflashnor_la_SOURCES = \
-       core.c \
-       tcl.c \
-       $(NOR_DRIVERS)
+noinst_LTLIBRARIES += %D%/libocdflashnor.la
+%C%_libocdflashnor_la_SOURCES = \
+       %D%/core.c \
+       %D%/tcl.c \
+       $(NOR_DRIVERS) \
+       %D%/drivers.c \
+       $(NORHEADERS)
 
 NOR_DRIVERS = \
-       aduc702x.c \
-       at91sam3.c \
-       at91sam7.c \
-       avrf.c \
-       cfi.c \
-       ecos.c \
-       faux.c \
-       lpc2000.c \
-       lpc288x.c \
-       lpc2900.c \
-       non_cfi.c \
-       ocl.c \
-       pic32mx.c \
-       stellaris.c \
-       stm32x.c \
-       str7x.c \
-       str9x.c \
-       str9xpec.c \
-       tms470.c
-
-noinst_HEADERS = \
-       at91sam7.h \
-       at91sam3.h \
-       avrf.h \
-       core.h \
-       cfi.h \
-       imp.h \
-       lpc2000.h \
-       lpc288x.h \
-       non_cfi.h \
-       ocl.h \
-       pic32mx.h \
-       stellaris.h \
-       stm32x.h \
-       str7x.h \
-       str9x.h \
-       str9xpec.h \
-       tms470.h
+       %D%/aduc702x.c \
+       %D%/aducm360.c \
+       %D%/ambiqmicro.c \
+       %D%/at91sam4.c \
+       %D%/at91sam4l.c \
+       %D%/at91samd.c \
+       %D%/at91sam3.c \
+       %D%/at91sam7.c \
+       %D%/ath79.c \
+       %D%/atsamv.c \
+       %D%/avrf.c \
+       %D%/bluenrg-x.c \
+       %D%/cc3220sf.c \
+       %D%/cc26xx.c \
+       %D%/cfi.c \
+       %D%/dsp5680xx_flash.c \
+       %D%/efm32.c \
+       %D%/em357.c \
+       %D%/faux.c \
+       %D%/fm3.c \
+       %D%/fm4.c \
+       %D%/jtagspi.c \
+       %D%/kinetis.c \
+       %D%/kinetis_ke.c \
+       %D%/lpc2000.c \
+       %D%/lpc288x.c \
+       %D%/lpc2900.c \
+       %D%/lpcspifi.c \
+       %D%/max32xxx.c \
+       %D%/mdr.c \
+       %D%/msp432.c \
+       %D%/mrvlqspi.c \
+       %D%/niietcm4.c \
+       %D%/non_cfi.c \
+       %D%/nrf5.c \
+       %D%/numicro.c \
+       %D%/ocl.c \
+       %D%/pic32mx.c \
+       %D%/psoc4.c \
+       %D%/psoc5lp.c \
+       %D%/psoc6.c \
+       %D%/sim3x.c \
+       %D%/spi.c \
+       %D%/stmsmi.c \
+       %D%/stellaris.c \
+       %D%/stm32f1x.c \
+       %D%/stm32f2x.c \
+       %D%/stm32lx.c \
+       %D%/stm32l4x.c \
+       %D%/stm32h7x.c \
+       %D%/str7x.c \
+       %D%/str9x.c \
+       %D%/str9xpec.c \
+       %D%/tms470.c \
+       %D%/virtual.c \
+       %D%/xcf.c \
+       %D%/xmc1xxx.c \
+       %D%/xmc4xxx.c
 
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+NORHEADERS = \
+       %D%/core.h \
+       %D%/cc3220sf.h \
+       %D%/cc26xx.h \
+       %D%/cfi.h \
+       %D%/driver.h \
+       %D%/imp.h \
+       %D%/non_cfi.h \
+       %D%/ocl.h \
+       %D%/spi.h \
+       %D%/msp432.h