]> git.sur5r.net Git - openocd/blobdiff - src/rtos/Makefile.am
rtos: add support for NuttX
[openocd] / src / rtos / Makefile.am
index c59ee3f8c7b430952202375a561abce0326c6516..c8c402303291224949b4fc895531b7c938fe66a8 100644 (file)
@@ -15,6 +15,7 @@ noinst_LTLIBRARIES += %D%/librtos.la
        %D%/embKernel.c \
        %D%/mqx.c \
        %D%/uCOS-III.c \
+       %D%/nuttx.c \
        %D%/rtos.h \
        %D%/rtos_standard_stackings.h \
        %D%/rtos_ecos_stackings.h \
@@ -22,7 +23,8 @@ noinst_LTLIBRARIES += %D%/librtos.la
        %D%/rtos_chibios_stackings.h \
        %D%/rtos_embkernel_stackings.h \
        %D%/rtos_mqx_stackings.h \
-       %D%/rtos_ucos_iii_stackings.h
+       %D%/rtos_ucos_iii_stackings.h \
+       %D%/nuttx_header.h
 
 %C%_librtos_la_CFLAGS = $(AM_CFLAGS)