]> git.sur5r.net Git - openocd/blobdiff - src/rtos/Makefile.am
rtos: add support for NuttX
[openocd] / src / rtos / Makefile.am
index e341caf0abea7c3e2c2ca2b7a46a64de9d613b3d..c8c402303291224949b4fc895531b7c938fe66a8 100644 (file)
@@ -1,34 +1,34 @@
-# ***************************************************************************
-# *   Copyright (C) 2011 by Broadcom Corporation                            *
-# *   Evan Hunter - ehunter@broadcom.com                                    *
-# *                                                                         *
-# *   This program is free software; you can redistribute it and/or modify  *
-# *   it under the terms of the GNU General Public License as published by  *
-# *   the Free Software Foundation; either version 2 of the License, or     *
-# *   (at your option) any later version.                                   *
-# *                                                                         *
-# *   This program is distributed in the hope that it will be useful,       *
-# *   but WITHOUT ANY WARRANTY; without even the implied warranty of        *
-# *   MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the         *
-# *   GNU General Public License for more details.                          *
-# *                                                                         *
-# *   You should have received a copy of the GNU General Public License     *
-# *   along with this program; if not, write to the                         *
-# *   Free Software Foundation, Inc.,                                       *
-# *   59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.             *
-# ***************************************************************************
+noinst_LTLIBRARIES += %D%/librtos.la
+%C%_librtos_la_SOURCES = \
+       %D%/rtos.c \
+       %D%/rtos_standard_stackings.c \
+       %D%/rtos_ecos_stackings.c  \
+       %D%/rtos_chibios_stackings.c \
+       %D%/rtos_embkernel_stackings.c \
+       %D%/rtos_mqx_stackings.c \
+       %D%/rtos_ucos_iii_stackings.c \
+       %D%/FreeRTOS.c \
+       %D%/ThreadX.c \
+       %D%/eCos.c \
+       %D%/linux.c \
+       %D%/ChibiOS.c \
+       %D%/embKernel.c \
+       %D%/mqx.c \
+       %D%/uCOS-III.c \
+       %D%/nuttx.c \
+       %D%/rtos.h \
+       %D%/rtos_standard_stackings.h \
+       %D%/rtos_ecos_stackings.h \
+       %D%/linux_header.h \
+       %D%/rtos_chibios_stackings.h \
+       %D%/rtos_embkernel_stackings.h \
+       %D%/rtos_mqx_stackings.h \
+       %D%/rtos_ucos_iii_stackings.h \
+       %D%/nuttx_header.h
 
-include $(top_srcdir)/common.mk
+%C%_librtos_la_CFLAGS = $(AM_CFLAGS)
 
-METASOURCES = AUTO
-noinst_LTLIBRARIES = librtos.la
-noinst_HEADERS = rtos.h rtos_standard_stackings.h rtos_ecos_stackings.h 
-librtos_la_SOURCES = rtos.c rtos_standard_stackings.c rtos_ecos_stackings.c FreeRTOS.c ThreadX.c eCos.c linux.c
-
-librtos_la_CFLAGS =
 if IS_MINGW
 # FD_* macros are sloppy with their signs on MinGW32 platform
-librtos_la_CFLAGS += -Wno-sign-compare
+%C%_librtos_la_CFLAGS += -Wno-sign-compare
 endif
-
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in