]> git.sur5r.net Git - openocd/blobdiff - src/target/Makefile.am
esirisc: support eSi-RISC targets
[openocd] / src / target / Makefile.am
index 0021f44d543802231d38eb03f56d33e222c02948..05f174870015938ee355d0c94ccf83c1f2d20c87 100644 (file)
@@ -4,7 +4,9 @@ else
 OOCD_TRACE_FILES =
 endif
 
-%C%_libtarget_la_LIBADD = %D%/openrisc/libopenrisc.la
+%C%_libtarget_la_LIBADD = %D%/openrisc/libopenrisc.la \
+       %D%/riscv/libriscv.la
+
 
 STARTUP_TCL_SRCS += %D%/startup.tcl
 
@@ -19,7 +21,9 @@ noinst_LTLIBRARIES += %D%/libtarget.la
        $(AVR32_SRC) \
        $(MIPS32_SRC) \
        $(NDS32_SRC) \
+       $(STM8_SRC) \
        $(INTEL_IA32_SRC) \
+       $(ESIRISC_SRC) \
        %D%/avrt.c \
        %D%/dsp563xx.c \
        %D%/dsp563xx_once.c \
@@ -38,6 +42,7 @@ TARGET_CORE_SRC = \
        %D%/target.c \
        %D%/target_request.c \
        %D%/testee.c \
+       %D%/semihosting_common.c \
        %D%/smp.c
 
 ARMV4_5_SRC = \
@@ -71,10 +76,12 @@ ARMV7_SRC = \
        %D%/cortex_m.c \
        %D%/armv7a.c \
        %D%/cortex_a.c \
-       %D%/ls1_sap.c
+       %D%/ls1_sap.c \
+       %D%/mem_ap.c
 
 ARMV8_SRC = \
        %D%/armv8_dpm.c \
+       %D%/armv8_opcodes.c \
        %D%/aarch64.c \
        %D%/armv8.c \
        %D%/armv8_cache.c
@@ -86,6 +93,7 @@ ARM_DEBUG_SRC = \
        %D%/arm_simulator.c \
        %D%/arm_semihosting.c \
        %D%/arm_adi_v5.c \
+       %D%/arm_dap.c \
        %D%/armv7a_cache.c \
        %D%/armv7a_cache_l2x.c \
        %D%/adi_v5_jtag.c \
@@ -95,7 +103,8 @@ ARM_DEBUG_SRC = \
        %D%/etb.c \
        %D%/etm.c \
        $(OOCD_TRACE_FILES) \
-       %D%/etm_dummy.c
+       %D%/etm_dummy.c \
+       %D%/arm_cti.c
 
 AVR32_SRC = \
        %D%/avr32_ap7k.c \
@@ -122,12 +131,19 @@ NDS32_SRC = \
        %D%/nds32_v3m.c \
        %D%/nds32_aice.c
 
+STM8_SRC = \
+       %D%/stm8.c
+
 INTEL_IA32_SRC = \
        %D%/quark_x10xx.c \
        %D%/quark_d20xx.c \
        %D%/lakemont.c \
        %D%/x86_32_common.c
 
+ESIRISC_SRC = \
+       %D%/esirisc.c \
+       %D%/esirisc_jtag.c
+
 %C%_libtarget_la_SOURCES += \
        %D%/algorithm.h \
        %D%/arm.h \
@@ -203,7 +219,14 @@ INTEL_IA32_SRC = \
        %D%/nds32_v3.h \
        %D%/nds32_v3m.h \
        %D%/nds32_aice.h \
+       %D%/semihosting_common.h \
+       %D%/stm8.h \
        %D%/lakemont.h \
-       %D%/x86_32_common.h
+       %D%/x86_32_common.h \
+       %D%/arm_cti.h \
+       %D%/esirisc.h \
+       %D%/esirisc_jtag.h \
+       %D%/esirisc_regs.h
 
 include %D%/openrisc/Makefile.am
+include %D%/riscv/Makefile.am