]> git.sur5r.net Git - tio/blobdiff - src/meson.build
Update upstream source from tag 'upstream/2.0'
[tio] / src / meson.build
index 464f4f3ea9ab8f40cd5cbed03db346f76ee44a02..00777330ce96020ea80bcdfa099bc8e583c5601f 100644 (file)
@@ -14,7 +14,10 @@ tio_sources = [
   'configfile.c',
   'signals.c',
   'socket.c',
-  'setspeed.c'
+  'setspeed.c',
+  'rs485.c',
+  'timestamp.c',
+  'alert.c'
 ]
 
 tio_dep = dependency('inih', required: true,
@@ -31,6 +34,10 @@ if enable_iossiospeed
   tio_c_args += '-DHAVE_IOSSIOSPEED'
 endif
 
+if enable_rs485
+  tio_c_args += '-DHAVE_RS485'
+endif
+
 executable('tio',
   tio_sources,
   c_args: tio_c_args,