]> git.sur5r.net Git - bacula/bacula/blob - bacula/platforms/contrib-rpm/rpmkey.spec
su102 again.
[bacula/bacula] / bacula / platforms / contrib-rpm / rpmkey.spec
1 # rpm public key package
2 # Copyright (C) 2006 Free Software Foundation Europe e.V.
3 #
4 #
5
6 # replace the string yournam with your name
7 # first initial and lastname, ie. sbarninger
8 %define pubkeyname yourname
9
10 # replace below with your name and email address
11 Packager: Your Name <your-email@site.org>
12
13 Summary: The %{pubkeyname} rpm public key
14 Name: rpmkey-%{pubkeyname}
15 Version: 0.1
16 Release: 1
17 License: GPL v2
18 Group: System/Packages
19 Source0: %{pubkeyname}.asc
20 BuildArch: noarch
21 BuildRoot: %{_tmppath}/%{name}-root
22
23 %define gpgkeypath /etc/bacula/pubkeys
24
25 %description
26 The %{pubkeyname} rpm public key. If you trust %{pubkeyname} component
27 and you want to import this key to the RPM database, then install this 
28 RPM. After installing this package you may import the key into your rpm
29 database, as root:
30
31 rpm --import %{gpgkeypath}/%{pubkeyname}.asc
32
33 %prep
34 %setup -c -T a1
35
36 %build
37
38 %install
39 mkdir -p %{buildroot}%{gpgkeypath}
40 cp -a %{SOURCE0} %{buildroot}%{gpgkeypath}/
41
42 %files
43 %defattr(-, root, root)
44 %{gpgkeypath}/%{pubkeyname}.asc
45
46
47 %changelog
48 * Sat Aug 19 2006 D. Scott Barninger <barninger@fairfieldcomputers.com
49 - change key directory to /etc/bacula/pubkeys
50 * Sun Jul 16 2006 D. Scott Barninger <barninger@fairfieldcomputers.com
51 - initial spec file