]> git.sur5r.net Git - bacula/bacula/blob - bacula/platforms/rpm/bacula-bat.spec
Add missing defines for gccver.
[bacula/bacula] / bacula / platforms / rpm / bacula-bat.spec
1 # Bacula RPM spec file
2 #
3 # Copyright (C) 2000-2009 Free Software Foundation Europe e.V.
4
5 # Platform Build Configuration
6
7 # basic defines for every build
8 %define _release           1
9 %define _version           5.0.0
10 %define depkgs_qt_version  28Jul09
11 %define _packager D. Scott Barninger <barninger@fairfieldcomputers.com>
12
13 %define manpage_ext gz
14
15 %define single_dir 0
16 %{?single_dir_install:%define single_dir 1}
17
18 # Installation Directory locations
19 %if %{single_dir}
20 %define _prefix        /opt/bacula
21 %define _sbindir       /opt/bacula/bin
22 %define _bindir        /opt/bacula/bin
23 %define _subsysdir     /opt/bacula/working
24 %define sqlite_bindir  /opt/bacula/sqlite
25 %define _mandir        /usr/share/man
26 %define sysconf_dir    /opt/bacula/etc
27 %define script_dir     /opt/bacula/scripts
28 %define working_dir    /opt/bacula/working
29 %define pid_dir        /opt/bacula/working
30 %define plugin_dir     /opt/bacula/plugins
31 %define lib_dir        /opt/bacula/lib
32 %else
33 %define _prefix        /usr
34 %define _sbindir       %_prefix/sbin
35 %define _bindir        %_prefix/bin
36 %define _subsysdir     /var/lock/subsys
37 %define sqlite_bindir  %_libdir/bacula/sqlite
38 %define _mandir        %_prefix/share/man
39 %define sysconf_dir    /etc/bacula
40 %define script_dir     %_libdir/bacula
41 %define working_dir    /var/lib/bacula
42 %define pid_dir        /var/run
43 %define plugin_dir     %_libdir/bacula/plugins
44 %define lib_dir        %_libdir/bacula/lib
45 %endif
46
47 # Daemon user:group Don't change them unless you know what you are doing
48 %define director_daemon_user    bacula
49 %define daemon_group            bacula
50
51 #--------------------------------------------------------------------------
52 # it should not be necessary to change anything below here for a release
53 # except for patch macros in the setup section
54 #--------------------------------------------------------------------------
55
56 %{?contrib_packager:%define _packager %{contrib_packager}}
57
58 %{expand: %%define gccver %(rpm -q --queryformat %%{version} gcc)}
59 %{expand: %%define gccrel %(rpm -q --queryformat %%{release} gcc)}
60
61 # determine what platform we are building on
62 %define fedora 0
63 %define suse 0
64 %define mdk 0
65
66 %if %{_vendor} == redhat
67         %define fedora 1
68         %define _dist %(cat /etc/redhat-release)
69 %endif
70 %if %{_vendor} == suse
71         %define suse 1
72         %define _dist %(grep -i SuSE /etc/SuSE-release)
73 %endif
74 %if %{_vendor} == Mandriva
75         %define mdk 1
76         %define _dist %(grep Mand /etc/mandrake-release)
77 %endif
78 %if ! %{fedora} && ! %{suse} && ! %{mdk}
79 %{error: Unknown platform. Please examine the spec file.}
80 exit 1
81 %endif
82
83 Summary: Bacula - The Network Backup Solution
84 Name: bacula-bat
85 Version: %{_version}
86 Release: %{_release}
87 Group: System Environment/Daemons
88 License: GPL v2
89 BuildRoot: %{_tmppath}/%{name}-root
90 URL: http://www.bacula.org/
91 Vendor: The Bacula Team
92 Packager: %{_packager}
93 Prefix: %{_prefix}
94 Distribution: %{_dist}
95
96 Source0: http://www.prdownloads.sourceforge.net/bacula/bacula-%{version}.tar.gz
97 Source1: http://www.prdownloads.sourceforge.net/bacula/depkgs-qt-%{depkgs_qt_version}.tar.gz
98
99 BuildRequires: gcc, gcc-c++, make, autoconf
100 BuildRequires: libstdc++-devel = %{gccver}-%{gccrel}, zlib-devel
101 BuildRequires: openssl-devel, fontconfig-devel, libpng-devel, libstdc++-devel, zlib-devel
102
103 Requires: openssl
104 Requires: fontconfig
105 Requires: freetype2
106 Requires: libgcc
107 Requires: libpng
108 Requires: libstdc++
109 Requires: zlib
110
111 %if %{suse}
112 Requires: /usr/bin/kdesu
113 Requires: freetype2
114 BuildRequires: freetype2-devel
115 %else
116 Requires: usermode
117 Requires: freetype
118 BuildRequires: freetype-devel
119 %endif
120
121 # Source directory locations
122 %define depkgs_qt ../depkgs-qt
123
124 # define the basic package description
125 %define blurb Bacula - It comes by night and sucks the vital essence from your computers.
126 %define blurb2 Bacula is a set of computer programs that permit you (or the system
127 %define blurb3 administrator) to manage backup, recovery, and verification of computer
128 %define blurb4 data across a network of computers of different kinds. In technical terms,
129 %define blurb5 it is a network client/server based backup program. Bacula is relatively
130 %define blurb6 easy to use and efficient, while offering many advanced storage management
131 %define blurb7 features that make it easy to find and recover lost or damaged files.
132 %define blurb8 Bacula source code has been released under the GPL version 2 license.
133
134 Summary: Bacula - The Network Backup Solution
135 Group: System Environment/Daemons
136
137 %description
138 %{blurb}
139
140 %{blurb2}
141 %{blurb3}
142 %{blurb4}
143 %{blurb5}
144 %{blurb6}
145 %{blurb7}
146 %{blurb8}
147
148 This is the Bacula Administration Tool (bat) graphical user interface package.
149 It is an add-on to the client or server packages.
150
151 %prep
152 %setup -T -n bacula-%{_version} -b 0
153 %setup -T -D -n bacula-%{_version} -b 1
154
155 %build
156
157
158 cwd=${PWD}
159 #export QTDIR=$(pkg-config --variable=prefix QtCore)
160 #export QTINC=$(pkg-config --variable=includedir QtCore)
161 #export QTLIB=$(pkg-config --variable=libdir QtCore)
162 #export PATH=${QTDIR}/bin/:${PATH}
163 cd %{depkgs_qt}
164 make qt4 <<EOF
165 yes
166 EOF
167 qtdir=${PWD}
168 export PATH=${qtdir}/qt4/bin:$PATH
169 export QTDIR=${qtdir}/qt4/
170 export QTINC=${qtdir}/qt4/include/
171 export QTLIB=${qtdir}/qt4/lib/
172 cd ${cwd}
173
174 # Main Bacula configuration with bat
175 %configure \
176         --prefix=%{_prefix} \
177         --sbindir=%{_sbindir} \
178         --sysconfdir=%{sysconf_dir} \
179         --mandir=%{_mandir} \
180         --with-scriptdir=%{script_dir} \
181         --with-working-dir=%{working_dir} \
182         --with-plugindir=%{script_dir} \
183         --with-pid-dir=%{pid_dir} \
184         --with-subsys-dir=%{_subsysdir} \
185         --enable-smartalloc \
186         --enable-bat \
187         --without-qwt \
188         --enable-client-only \
189         --with-dir-user=%{director_daemon_user} \
190         --with-dir-group=%{daemon_group} \
191         --with-sd-user=%{storage_daemon_user} \
192         --with-sd-group=%{storage_daemon_group} \
193         --with-fd-user=%{file_daemon_user} \
194         --with-fd-group=%{daemon_group} \
195         --with-dir-password="XXX_REPLACE_WITH_DIRECTOR_PASSWORD_XXX" \
196         --with-fd-password="XXX_REPLACE_WITH_CLIENT_PASSWORD_XXX" \
197         --with-sd-password="XXX_REPLACE_WITH_STORAGE_PASSWORD_XXX" \
198         --with-mon-dir-password="XXX_REPLACE_WITH_DIRECTOR_MONITOR_PASSWORD_XXX" \
199         --with-mon-fd-password="XXX_REPLACE_WITH_CLIENT_MONITOR_PASSWORD_XXX" \
200         --with-mon-sd-password="XXX_REPLACE_WITH_STORAGE_MONITOR_PASSWORD_XXX" \
201         --with-openssl
202
203 make
204
205 %install
206 mkdir -p $RPM_BUILD_ROOT/usr/share/applications
207 mkdir -p $RPM_BUILD_ROOT/usr/share/pixmaps
208 %if ! %{suse}
209 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
210 mkdir -p $RPM_BUILD_ROOT/etc/security/console.apps
211 mkdir -p $RPM_BUILD_ROOT%{_sbindir}
212 mkdir -p $RPM_BUILD_ROOT/usr/bin
213 %endif
214
215 cd src/qt-console
216 make DESTDIR=$RPM_BUILD_ROOT install
217 cd ../..
218
219 rm -rf $RPM_BUILD_ROOT%{_prefix}/share/doc/bacula
220
221 %if %{suse}
222 cp -p src/qt-console/images/bat_icon.png $RPM_BUILD_ROOT/usr/share/pixmaps/bat_icon.png
223 cp -p scripts/bat.desktop.xsu $RPM_BUILD_ROOT/usr/share/applications/bat.desktop
224 touch RPM_BUILD_ROOT%{sysconfdir}/bat.kdesu
225 %else
226 cp -p src/qt-console/images/bat_icon.png $RPM_BUILD_ROOT/usr/share/pixmaps/bat_icon.png
227 cp -p scripts/bat.desktop.consolehelper $RPM_BUILD_ROOT/usr/share/applications/bat.desktop
228 cp -p scripts/bat.console_apps $RPM_BUILD_ROOT/etc/security/console.apps/bat
229 cp -p scripts/bat.pamd $RPM_BUILD_ROOT/etc/pam.d/bat
230 ln -sf consolehelper $RPM_BUILD_ROOT/usr/bin/bat
231 %endif
232
233 %files
234 %defattr(-,root,root)
235 %attr(-, root, %{daemon_group}) %{_sbindir}/bat
236 %attr(-, root, %{daemon_group}) %dir %{sysconf_dir}
237 %attr(-, root, %{daemon_group}) %config(noreplace) %{sysconf_dir}/bat.conf
238 /usr/share/pixmaps/bat_icon.png
239 /usr/share/applications/bat.desktop
240
241 # if user is a member of daemon_group then kdesu will run bat as user
242 %if %{suse}
243 %attr(0660, root, %{daemon_group}) %{sysconf_dir}/bat.kdesu
244 %endif
245
246 %if ! %{suse}
247 # add the console helper files
248 %config(noreplace,missingok) /etc/pam.d/bat
249 %config(noreplace,missingok) /etc/security/console.apps/bat
250 /usr/bin/bat
251 %endif
252
253 %pre
254 # create the daemon group
255 HAVE_BACULA=`grep %{daemon_group} %{group_file} 2>/dev/null`
256 if [ -z "$HAVE_BACULA" ]; then
257     %{groupadd} -r %{daemon_group} > /dev/null 2>&1
258     echo "The group %{daemon_group} has been added to %{group_file}."
259     echo "See the manual chapter \"Running Bacula\" for details."
260 fi
261
262
263 %post
264 if [ -d %{sysconf_dir} ]; then
265    cd %{sysconf_dir}
266    for string in XXX_REPLACE_WITH_DIRECTOR_PASSWORD_XXX XXX_REPLACE_WITH_CLIENT_PASSWORD_XXX XXX_REPLACE_WITH_STORAGE_PASSWORD_XXX XXX_REPLACE_WITH_DIRECTOR_MONITOR_PASSWORD_XXX XXX_REPLACE_WITH_CLIENT_MONITOR_PASSWORD_XXX XXX_REPLACE_WITH_STORAGE_MONITOR_PASSWORD_XXX; do
267       pass=`openssl rand -base64 33`
268       for file in *.conf; do
269          need_password=`grep ${string} $file 2>/dev/null`
270          if [ -n "$need_password" ]; then
271             sed "s@${string}@${pass}@g" $file > $file.new
272             cp -f $file.new $file; rm -f $file.new
273          fi
274       done
275    done
276 # put actual hostname in conf file
277    host=`hostname`
278    string="XXX_HOSTNAME_XXX"
279    for file in *.conf; do
280       need_host=`grep ${string} $file 2>/dev/null`
281       if [ -n "$need_host" ]; then
282          sed "s@${string}@${host}@g" $file >$file.new
283          cp -f $file.new $file; rm -f $file.new
284       fi
285    done
286 fi
287 /sbin/ldconfig
288
289 %clean
290 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf "$RPM_BUILD_ROOT"
291 rm -rf $RPM_BUILD_DIR/depkgs-qt
292
293 %changelog
294 * Sat Feb 13 2010 D. Scott Barninger <barninger@fairfieldcomputers.com>
295 - create file to allow bat to run nonroot with kdesu
296 - add dependency information
297 * Sat Jan 30 2010 D. Scott Barninger <barninger@fairfieldcomputers.com>
298 - fix consolehelper/xsu for suse packages
299 * Sat Aug 1 2009 Kern Sibbald <kern@sibbald.com>
300 - Split bat into separate bacula-bat.spec