]> git.sur5r.net Git - bacula/bacula/blob - bacula/platforms/rpm/bacula-bat.spec
Changes to run bat as nonroot user.
[bacula/bacula] / bacula / platforms / rpm / bacula-bat.spec
1 # Bacula RPM spec file
2 #
3 # Copyright (C) 2000-2009 Free Software Foundation Europe e.V.
4
5 # Platform Build Configuration
6
7 # basic defines for every build
8 %define _release           1
9 %define _version           5.0.0
10 %define depkgs_qt_version  28Jul09
11 %define _packager D. Scott Barninger <barninger@fairfieldcomputers.com>
12
13 %define manpage_ext gz
14
15 %define single_dir 0
16 %{?single_dir_install:%define single_dir 1}
17
18 # Installation Directory locations
19 %if %{single_dir}
20 %define _prefix        /opt/bacula
21 %define _sbindir       /opt/bacula/bin
22 %define _bindir        /opt/bacula/bin
23 %define _subsysdir     /opt/bacula/working
24 %define sqlite_bindir  /opt/bacula/sqlite
25 %define _mandir        /usr/share/man
26 %define sysconf_dir    /opt/bacula/etc
27 %define script_dir     /opt/bacula/scripts
28 %define working_dir    /opt/bacula/working
29 %define pid_dir        /opt/bacula/working
30 %define plugin_dir     /opt/bacula/plugins
31 %define lib_dir        /opt/bacula/lib
32 %else
33 %define _prefix        /usr
34 %define _sbindir       %_prefix/sbin
35 %define _bindir        %_prefix/bin
36 %define _subsysdir     /var/lock/subsys
37 %define sqlite_bindir  %_libdir/bacula/sqlite
38 %define _mandir        %_prefix/share/man
39 %define sysconf_dir    /etc/bacula
40 %define script_dir     %_libdir/bacula
41 %define working_dir    /var/lib/bacula
42 %define pid_dir        /var/run
43 %define plugin_dir     %_libdir/bacula/plugins
44 %define lib_dir        %_libdir/bacula/lib
45 %endif
46
47 # Daemon user:group Don't change them unless you know what you are doing
48 %define director_daemon_user    bacula
49 %define daemon_group            bacula
50
51 #--------------------------------------------------------------------------
52 # it should not be necessary to change anything below here for a release
53 # except for patch macros in the setup section
54 #--------------------------------------------------------------------------
55
56 %{?contrib_packager:%define _packager %{contrib_packager}}
57
58 # determine what platform we are building on
59 %define fedora 0
60 %define suse 0
61 %define mdk 0
62
63 %if %{_vendor} == redhat
64         %define fedora 1
65         %define _dist %(cat /etc/redhat-release)
66 %endif
67 %if %{_vendor} == suse
68         %define suse 1
69         %define _dist %(grep -i SuSE /etc/SuSE-release)
70 %endif
71 %if %{_vendor} == Mandriva
72         %define mdk 1
73         %define _dist %(grep Mand /etc/mandrake-release)
74 %endif
75 %if ! %{fedora} && ! %{suse} && ! %{mdk}
76 %{error: Unknown platform. Please examine the spec file.}
77 exit 1
78 %endif
79
80 Summary: Bacula - The Network Backup Solution
81 Name: bacula-bat
82 Version: %{_version}
83 Release: %{_release}
84 Group: System Environment/Daemons
85 License: GPL v2
86 BuildRoot: %{_tmppath}/%{name}-root
87 URL: http://www.bacula.org/
88 Vendor: The Bacula Team
89 Packager: %{_packager}
90 Prefix: %{_prefix}
91 Distribution: %{_dist}
92
93 Source0: http://www.prdownloads.sourceforge.net/bacula/bacula-%{version}.tar.gz
94 Source1: http://www.prdownloads.sourceforge.net/bacula/depkgs-qt-%{depkgs_qt_version}.tar.gz
95
96
97 # Source directory locations
98 %define depkgs_qt ../depkgs-qt
99
100 # define the basic package description
101 %define blurb Bacula - It comes by night and sucks the vital essence from your computers.
102 %define blurb2 Bacula is a set of computer programs that permit you (or the system
103 %define blurb3 administrator) to manage backup, recovery, and verification of computer
104 %define blurb4 data across a network of computers of different kinds. In technical terms,
105 %define blurb5 it is a network client/server based backup program. Bacula is relatively
106 %define blurb6 easy to use and efficient, while offering many advanced storage management
107 %define blurb7 features that make it easy to find and recover lost or damaged files.
108 %define blurb8 Bacula source code has been released under the GPL version 2 license.
109
110 Summary: Bacula - The Network Backup Solution
111 Group: System Environment/Daemons
112
113 %description
114 %{blurb}
115
116 %{blurb2}
117 %{blurb3}
118 %{blurb4}
119 %{blurb5}
120 %{blurb6}
121 %{blurb7}
122 %{blurb8}
123
124 This is the Bacula Administration Tool (bat) graphical user interface package.
125 It is an add-on to the client or server packages.
126
127 %prep
128 %setup -T -n bacula-%{_version} -b 0
129 %setup -T -D -n bacula-%{_version} -b 1
130
131 %build
132
133
134 cwd=${PWD}
135 #export QTDIR=$(pkg-config --variable=prefix QtCore)
136 #export QTINC=$(pkg-config --variable=includedir QtCore)
137 #export QTLIB=$(pkg-config --variable=libdir QtCore)
138 #export PATH=${QTDIR}/bin/:${PATH}
139 cd %{depkgs_qt}
140 make qt4 <<EOF
141 yes
142 EOF
143 qtdir=${PWD}
144 export PATH=${qtdir}/qt4/bin:$PATH
145 export QTDIR=${qtdir}/qt4/
146 export QTINC=${qtdir}/qt4/include/
147 export QTLIB=${qtdir}/qt4/lib/
148 cd ${cwd}
149
150 # Main Bacula configuration with bat
151 %configure \
152         --prefix=%{_prefix} \
153         --sbindir=%{_sbindir} \
154         --sysconfdir=%{sysconf_dir} \
155         --mandir=%{_mandir} \
156         --with-scriptdir=%{script_dir} \
157         --with-working-dir=%{working_dir} \
158         --with-plugindir=%{script_dir} \
159         --with-pid-dir=%{pid_dir} \
160         --with-subsys-dir=%{_subsysdir} \
161         --enable-smartalloc \
162         --enable-bat \
163         --without-qwt \
164         --enable-client-only \
165         --with-dir-user=%{director_daemon_user} \
166         --with-dir-group=%{daemon_group} \
167         --with-sd-user=%{storage_daemon_user} \
168         --with-sd-group=%{storage_daemon_group} \
169         --with-fd-user=%{file_daemon_user} \
170         --with-fd-group=%{daemon_group} \
171         --with-dir-password="XXX_REPLACE_WITH_DIRECTOR_PASSWORD_XXX" \
172         --with-fd-password="XXX_REPLACE_WITH_CLIENT_PASSWORD_XXX" \
173         --with-sd-password="XXX_REPLACE_WITH_STORAGE_PASSWORD_XXX" \
174         --with-mon-dir-password="XXX_REPLACE_WITH_DIRECTOR_MONITOR_PASSWORD_XXX" \
175         --with-mon-fd-password="XXX_REPLACE_WITH_CLIENT_MONITOR_PASSWORD_XXX" \
176         --with-mon-sd-password="XXX_REPLACE_WITH_STORAGE_MONITOR_PASSWORD_XXX" \
177         --with-openssl
178
179 make
180
181 %install
182 mkdir -p $RPM_BUILD_ROOT/usr/share/applications
183 mkdir -p $RPM_BUILD_ROOT/usr/share/pixmaps
184 %if ! %{suse}
185 mkdir -p $RPM_BUILD_ROOT/etc/pam.d
186 mkdir -p $RPM_BUILD_ROOT/etc/security/console.apps
187 mkdir -p $RPM_BUILD_ROOT%{_sbindir}
188 mkdir -p $RPM_BUILD_ROOT/usr/bin
189 %endif
190
191 cd src/qt-console
192 make DESTDIR=$RPM_BUILD_ROOT install
193 cd ../..
194
195 rm -rf $RPM_BUILD_ROOT%{_prefix}/share/doc/bacula
196
197 %if %{suse}
198 cp -p src/qt-console/images/bat_icon.png $RPM_BUILD_ROOT/usr/share/pixmaps/bat_icon.png
199 cp -p scripts/bat.desktop.xsu $RPM_BUILD_ROOT/usr/share/applications/bat.desktop
200 touch RPM_BUILD_ROOT%{sysconfdir}/bat.kdesu
201 %else
202 cp -p src/qt-console/images/bat_icon.png $RPM_BUILD_ROOT/usr/share/pixmaps/bat_icon.png
203 cp -p scripts/bat.desktop.consolehelper $RPM_BUILD_ROOT/usr/share/applications/bat.desktop
204 cp -p scripts/bat.console_apps $RPM_BUILD_ROOT/etc/security/console.apps/bat
205 cp -p scripts/bat.pamd $RPM_BUILD_ROOT/etc/pam.d/bat
206 ln -sf consolehelper $RPM_BUILD_ROOT/usr/bin/bat
207 %endif
208
209 %files
210 %defattr(-,root,root)
211 %attr(-, root, %{daemon_group}) %{_sbindir}/bat
212 %attr(-, root, %{daemon_group}) %dir %{sysconf_dir}
213 %attr(-, root, %{daemon_group}) %config(noreplace) %{sysconf_dir}/bat.conf
214 /usr/share/pixmaps/bat_icon.png
215 /usr/share/applications/bat.desktop
216
217 # if user is a member of daemon_group then kdesu will run bat as user
218 %if %{suse}
219 %attr(0660, root, %{daemon_group}) %{sysconf_dir}/bat.kdesu
220 %endif
221
222 %if ! %{suse}
223 # add the console helper files
224 %config(noreplace,missingok) /etc/pam.d/bat
225 %config(noreplace,missingok) /etc/security/console.apps/bat
226 /usr/bin/bat
227 %endif
228
229 %pre
230 # create the daemon group
231 HAVE_BACULA=`grep %{daemon_group} %{group_file} 2>/dev/null`
232 if [ -z "$HAVE_BACULA" ]; then
233     %{groupadd} -r %{daemon_group} > /dev/null 2>&1
234     echo "The group %{daemon_group} has been added to %{group_file}."
235     echo "See the manual chapter \"Running Bacula\" for details."
236 fi
237
238
239 %post
240 if [ -d %{sysconf_dir} ]; then
241    cd %{sysconf_dir}
242    for string in XXX_REPLACE_WITH_DIRECTOR_PASSWORD_XXX XXX_REPLACE_WITH_CLIENT_PASSWORD_XXX XXX_REPLACE_WITH_STORAGE_PASSWORD_XXX XXX_REPLACE_WITH_DIRECTOR_MONITOR_PASSWORD_XXX XXX_REPLACE_WITH_CLIENT_MONITOR_PASSWORD_XXX XXX_REPLACE_WITH_STORAGE_MONITOR_PASSWORD_XXX; do
243       pass=`openssl rand -base64 33`
244       for file in *.conf; do
245          need_password=`grep ${string} $file 2>/dev/null`
246          if [ -n "$need_password" ]; then
247             sed "s@${string}@${pass}@g" $file > $file.new
248             cp -f $file.new $file; rm -f $file.new
249          fi
250       done
251    done
252 # put actual hostname in conf file
253    host=`hostname`
254    string="XXX_HOSTNAME_XXX"
255    for file in *.conf; do
256       need_host=`grep ${string} $file 2>/dev/null`
257       if [ -n "$need_host" ]; then
258          sed "s@${string}@${host}@g" $file >$file.new
259          cp -f $file.new $file; rm -f $file.new
260       fi
261    done
262 fi
263 /sbin/ldconfig
264
265 %clean
266 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf "$RPM_BUILD_ROOT"
267 rm -rf $RPM_BUILD_DIR/depkgs-qt
268
269 %changelog
270 * Sat Feb 13 2010 D. Scott Barninger <barninger@fairfieldcomputers.com>
271 - create file to allow bat to run nonroot with kdesu
272 * Sat Jan 30 2010 D. Scott Barninger <barninger@fairfieldcomputers.com>
273 - fix consolehelper/xsu for suse packages
274 * Sat Aug 1 2009 Kern Sibbald <kern@sibbald.com>
275 - Split bat into separate bacula-bat.spec