]> git.sur5r.net Git - bacula/bacula/blobdiff - bacula/platforms/rpm/bacula-bat.spec
Update spec files
[bacula/bacula] / bacula / platforms / rpm / bacula-bat.spec
index 33a7b4595321ab0d4509166ba85760bd8e62ee77..9c7d9a12164721e6c87d366873b90cd50dcb460c 100644 (file)
@@ -6,7 +6,7 @@
 
 # basic defines for every build
 %define _release           1
-%define _version           5.0.1
+%define _version           5.0.3
 %define depkgs_qt_version  28Jul09
 
 # this is the QT version in depkgs_qt
 %{expand: %%define gccver %(rpm -q --queryformat %%{version} gcc)}
 %{expand: %%define gccrel %(rpm -q --queryformat %%{release} gcc)}
 
+%define staticqt 1
+%{?nobuild_staticqt:%define staticqt 0}
+
 # determine what platform we are building on
 %define fedora 0
 %define suse 0
 %define mdk 0
 
 %if %{_vendor} == redhat
-       %define fedora 1
-       %define _dist %(cat /etc/redhat-release)
+        %define fedora 1
+        %define _dist %(cat /etc/redhat-release)
 %endif
 %if %{_vendor} == suse
-       %define suse 1
-       %define _dist %(grep -i SuSE /etc/SuSE-release)
+        %define suse 1
+        %define _dist %(grep -i SuSE /etc/SuSE-release)
 %endif
 %if %{_vendor} == Mandriva
-       %define mdk 1
-       %define _dist %(grep Mand /etc/mandrake-release)
+        %define mdk 1
+        %define _dist %(grep Mand /etc/mandrake-release)
 %endif
 %if ! %{fedora} && ! %{suse} && ! %{mdk}
 %{error: Unknown platform. Please examine the spec file.}
@@ -89,7 +92,7 @@ Name: bacula-bat
 Version: %{_version}
 Release: %{_release}
 Group: System Environment/Daemons
-License: GPL v2
+License: AGPLv3
 BuildRoot: %{_tmppath}/%{name}-root
 URL: http://www.bacula.org/
 Vendor: The Bacula Team
@@ -126,14 +129,14 @@ BuildRequires: freetype-devel
 %define depkgs_qt ../depkgs-qt
 
 # define the basic package description
-%define blurb Bacula - It comes by night and sucks the vital essence from your computers.
+%define blurb Bacula - The Leading Open Source Backup Solution.
 %define blurb2 Bacula is a set of computer programs that permit you (or the system
 %define blurb3 administrator) to manage backup, recovery, and verification of computer
 %define blurb4 data across a network of computers of different kinds. In technical terms,
 %define blurb5 it is a network client/server based backup program. Bacula is relatively
 %define blurb6 easy to use and efficient, while offering many advanced storage management
 %define blurb7 features that make it easy to find and recover lost or damaged files.
-%define blurb8 Bacula source code has been released under the GPL version 2 license.
+%define blurb8 Bacula source code has been released under the AGPL version 3 license.
 
 Summary: Bacula - The Network Backup Solution
 Group: System Environment/Daemons
@@ -160,10 +163,12 @@ It is an add-on to the client or server packages.
 
 
 cwd=${PWD}
-#export QTDIR=$(pkg-config --variable=prefix QtCore)
-#export QTINC=$(pkg-config --variable=includedir QtCore)
-#export QTLIB=$(pkg-config --variable=libdir QtCore)
-#export PATH=${QTDIR}/bin/:${PATH}
+%if ! %{staticqt}
+export QTDIR=$(pkg-config --variable=prefix QtCore)
+export QTINC=$(pkg-config --variable=includedir QtCore)
+export QTLIB=$(pkg-config --variable=libdir QtCore)
+export PATH=${QTDIR}/bin/:${PATH}
+%else
 cd %{depkgs_qt}
 make qt4 <<EOF
 yes
@@ -175,6 +180,7 @@ export QTINC=${qtdir}/qt4/include/
 export QTLIB=${qtdir}/qt4/lib/
 export QMAKESPEC=${qtdir}/qt-x11-opensource-src-%{qt4ver}/mkspecs/linux-g++/
 cd ${cwd}
+%endif
 
 # Main Bacula configuration with bat
 %configure \
@@ -298,6 +304,7 @@ rm -rf $RPM_BUILD_DIR/depkgs-qt
 %changelog
 * Sun Mar 14 2010 D. Scott Barninger <barninger@fairfieldcomputers.com>
 - Fix for QT mkspecs location on FC12
+- allow user to build without embedded static QT
 * Sat Feb 27 2010 D. Scott Barninger <barninger@fairfieldcomputers.com>
 - add dependency on bacula-libs
 * Sat Feb 13 2010 D. Scott Barninger <barninger@fairfieldcomputers.com>