]> git.sur5r.net Git - bacula/bacula/blobdiff - bacula/autoconf/configure.in
This commit was manufactured by cvs2svn to create tag
[bacula/bacula] / bacula / autoconf / configure.in
index 44a88459e332833fde88f3ffa287fa302fc608d9..3acb70181af408aa8c07d2af37a65add25ca53ae 100644 (file)
@@ -193,7 +193,6 @@ support_conio=yes
 support_gnome=no
 support_wx_console=no
 support_tls=no
-support_crypto=no
 gnome_version=
 wx_version=
 support_static_tools=no
@@ -752,34 +751,19 @@ if test "x$with_openssl_directory" != "x"; then
 
        AC_TRY_LINK([ #include <openssl/ssl.h> ],
                [ CRYPTO_set_id_callback(NULL); ],
-               [
-                       support_tls="yes"
-                       support_crypto="yes"
-               ],
+               [ support_tls="yes" ],
                [ support_tls="no" ]
        )
 
-       AC_TRY_LINK([ #include <openssl/evp.h> ],
-               [ EVP_sha512(); ],
-               [ ac_cv_openssl_sha2="yes" ],
-               [ ac_cv_openssl_sha2="no" ]
-       )
-
        LIBS="$saved_LIBS"
        CFLAGS="$saved_CFLAGS"
 
        if test "$support_tls" = "yes"; then
                AC_DEFINE(HAVE_OPENSSL, 1, [Define if OpenSSL library is available])
                AC_DEFINE(HAVE_TLS, 1, [Define if TLS support should be enabled])
-               AC_DEFINE(HAVE_CRYPTO, 1, [Define if encryption support should be enabled])
-       fi
-
-       if test "$ac_cv_openssl_sha2" = "yes"; then
-               AC_DEFINE(HAVE_SHA2, 1, [Define if the SHA-2 family of digest algorithms is available])
        fi
 else
        support_tls="no"
-       support_crypto="no"
        OPENSSL_LIBS=""
        OPENSSL_INC=""
 fi
@@ -1996,7 +1980,6 @@ AC_OUTPUT([autoconf/Make.common \
           src/cats/drop_bacula_tables \
           src/cats/drop_bacula_database \
           src/findlib/Makefile \
-          src/pygtk-console/Makefile \
           src/tools/Makefile \
           src/win32/winbacula.nsi \
           src/win32/baculafd/bacula-fd.conf \
@@ -2131,7 +2114,6 @@ Configuration on `date`:
   readline support:          ${got_readline} ${PRTREADLINE_SRC}
   TCP Wrappers support:       ${TCPW_MSG} ${WRAPLIBS}
   TLS support:               ${support_tls}
-  Encryption support:        ${support_crypto} 
   ZLIB support:              ${have_zlib}
   enable-smartalloc:         ${support_smartalloc} 
   enable-gnome:              ${support_gnome} ${gnome_version}