]> git.sur5r.net Git - bacula/bacula/blobdiff - bacula/platforms/rpms/redhat/bacula.spec.in
rpm: Fix MySQL dependency on bacula-postgresql package
[bacula/bacula] / bacula / platforms / rpms / redhat / bacula.spec.in
index eae9b5dede34c599afcfd96f33cc2bd40e2b42d3..7563c275d81da3640fb3b06f3df825cddcc82880 100644 (file)
@@ -128,6 +128,10 @@ Source2: Release_Notes-%{version}-%{release}.tar.gz
 %{?build_fc22:%define fc22 1}
 %define fc25 0
 %{?build_fc25:%define fc25 1}
+%define fc26 0
+%{?build_fc26:%define fc26 1}
+%define fc27 0
+%{?build_fc27:%define fc27 1}
 # RedHat Enterprise builds
 %define rhel3 0
 %{?build_rhel3:%define rhel3 1}
@@ -204,7 +208,7 @@ Source2: Release_Notes-%{version}-%{release}.tar.gz
 # if the platform is using systemd
 %define usesystemd 0
 
-%if %{rhel7} || %{fc22}|| %{fc25} || %{centos7}
+%if %{rhel7} || %{fc22}|| %{fc25} || %{fc26} || %{fc27} || %{centos7}
 %define usesystemd 1
 %endif
 
@@ -223,7 +227,7 @@ Source2: Release_Notes-%{version}-%{release}.tar.gz
 %define rhat 1
 %endif
 %define fed 0
-%if %{fc16} || %{fc17} || %{fc18} || %{fc22} || %{fc25}
+%if %{fc16} || %{fc17} || %{fc18} || %{fc22} || %{fc25} || %{fc26} || %{fc27}
 %define fed 1
 %endif
 %define suse 0
@@ -286,7 +290,7 @@ exit 1
 %{?build_x86_64:%define x86_64 1}
 
 # check what distribution we are
-%if %{fc16} || %{fc17} || %{fc18} || %{fc22} || %{fc25}
+%if %{fc16} || %{fc17} || %{fc18} || %{fc22} || %{fc25} || %{fc26} || %{fc27}
 %define _dist %(grep Fedora /etc/redhat-release)
 %endif
 %if %{centos7} || %{centos6}
@@ -372,7 +376,7 @@ BuildRequires: %{postgres_devel_package} >= %{postgres_version}
 #
 %if %{mysql}
 %package mysql
-Provides: libbaccats-%{version}.so()(64bit)
+Provides: bacula-mysql
 #
 # The following provides is to work around an 
 #  auto generated requires from src/scripts/logwatch/applybaculadate
@@ -382,11 +386,13 @@ Provides: perl(Logwatch)
 %endif
 %if %{postgresql}
 %package postgresql
+Provides: bacula-postgresql
 %endif
 
 Summary: Bacula - The Network Backup Solution
 Group: System Environment/Daemons
 Provides: bacula-dir, bacula-sd, bacula-fd, bacula-server
+Provides: libbaccats-%{version}.so()(64bit)
 Conflicts: bacula-client
 
 Requires: ncurses, libstdc++, zlib, openssl
@@ -855,6 +861,7 @@ rm -f $RPM_BUILD_DIR/Release_Notes-%{version}-%{release}.txt
 %attr(-, root, %{daemon_group}) %{script_dir}/bacula-ctl-fd
 %attr(-, root, %{daemon_group}) %{script_dir}/bacula-ctl-sd
 %attr(-, root, %{daemon_group}) %{script_dir}/tapealert
+%attr(-, root, %{daemon_group}) %{script_dir}/baculabackupreport
 
 %attr(-, root, %{daemon_group}) %{plugin_dir}/bpipe-fd.so
 %attr(-, root, %{daemon_group}) %{_sbindir}/dbcheck
@@ -924,6 +931,8 @@ rm -f $RPM_BUILD_DIR/Release_Notes-%{version}-%{release}.txt
 %{_mandir}/man1/bat.1.%{manpage_ext}
 %_prefix/share/doc/*
 
+%attr(-, root, %{daemon_group}) %{script_dir}/bacula-tray-monitor.desktop
+
 %doc ../Release_Notes-%{version}-%{release}.txt
 
 %endif