]> git.sur5r.net Git - bacula/rescue/blobdiff - rescue/autoconf/configure.in
Enhance makefiles
[bacula/rescue] / rescue / autoconf / configure.in
index 94a4619563cad8717f7366b8e7b5b92041e879b1..37fb26f47a8aa9eb5b33c0be6e00d1ee76d00c3e 100644 (file)
@@ -86,11 +86,70 @@ if test ! x$CDRECORD = x ; then
 fi
 AC_SUBST(CDSTL)
 
-
 dnl# --------------------------------------------------------------------------
 dnl# CHECKING COMMAND LINE OPTIONS
 dnl# --------------------------------------------------------------------------
 
+# -------------------------------------------
+# static-fd    (default off)
+# -------------------------------------------
+AC_ARG_ENABLE(static-fd,
+   [  --enable-static-fd      enable static File daemon [disabled]],
+   [if test x$enableval = xyes; then
+     support_static_fd=yes
+   fi])
+
+STATIC_FD=
+if test x$support_static_fd = xyes; then
+   STATIC_FD="static-bacula-fd"
+fi
+AC_SUBST(STATIC_FD)
+
+where=
+# ------------------------------------------
+# Where to get iso
+# ------------------------------------------
+AC_ARG_WITH(iso,
+   [  --with-iso=PATH   specify path to iso],
+   [
+       if test "x$withval" != "xno" ; then     
+          where=$withval
+          type=iso
+       fi
+   ]
+)
+AC_SUBST(iso)
+
+# ------------------------------------------
+# Where to get cdrom
+# ------------------------------------------
+AC_ARG_WITH(cdrom,
+   [  --with-cdrom=PATH    specify path to cdrom],
+   [
+       if test "x$withval" != "xno" ; then     
+         where=$withval
+         type=cdrom
+       fi
+   ]
+)
+
+AC_SUBST(where)
+AC_SUBST(type)
+
+# ------------------------------------------
+# Where to get Bacula source
+# ------------------------------------------
+AC_ARG_WITH(bacula,
+   [  --with-bacula=PATH    specify path to bacula],
+   [
+       if test "x$withval" != "xno" ; then     
+         bacula=$withval
+       fi
+   ]
+)
+
+AC_SUBST(bacula)
+
 
 #
 # Finally we set appropriate distribution specific
@@ -210,7 +269,9 @@ Configuration on `date`:
 
   Host:                      $host -- ${DISTNAME} ${DISTVER}
   Rescue version:            ${VERSION} (${DATE})
-  Source code location:       ${srcdir}
+  Source code location:       ${bacula}
+  Rescue disk image type:     ${type}
+  Rescue disk image location: ${where}
 
 
   " > config.out