]> git.sur5r.net Git - glabels/blob - barcode-0.98/barcode.spec
Imported Upstream version 2.2.8
[glabels] / barcode-0.98 / barcode.spec
1 %define name    barcode
2 %define ver     0.98
3 %define rel     1
4 %define prefix   /usr
5 %define sysconfdir      /etc
6
7 Summary: GNU barcode
8 Name: %name
9 Version: %ver
10 Release: %rel
11 Copyright: GPL
12 Group: Applications/Productivity
13 Source:  ftp://ar.linux.it/pub/barcode/%name-%{ver}.tar.gz
14 BuildRoot: /var/tmp/%name-%{ver}-root
15 URL: http://gnu.systemy.it/software/barcode
16 Prefix: %prefix
17
18 %description
19 This is GNU-barcode.
20 The package is meant to solve most needs in barcode creation with a
21 conventional printer. It can create printouts for the conventional
22 product tagging standards: UPC-A, UPC-E, EAN-13, EAN-8, ISBN, as well
23 as a few other formats. Ouput is generated as either Postscript or
24 Encapsulated Postscript (other back-ends may be added if needed).
25
26 %package devel
27 Summary: GNU barcode files for development
28 Group: Development/Libraries
29
30 %description devel
31 This is GNU-barcode.
32 The package is meant to solve most needs in barcode creation with a
33 conventional printer. It can create printouts for the conventional
34 product tagging standards: UPC-A, UPC-E, EAN-13, EAN-8, ISBN, as well
35 as a few other formats. Ouput is generated as either Postscript or
36 Encapsulated Postscript (other back-ends may be added if needed).
37
38 This package contain the C header, the static library and man page
39 for development.
40
41 %prep
42 %setup
43
44 %ifarch alpha
45   ARCH_FLAGS="--host=alpha-redhat-linux"
46 %endif
47
48 export -n LANG LINGUAS LC_ALL 
49 if [ ! -f configure ]; then
50   CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh $ARCH_FLAGS --prefix=%{prefix} --sysconfdir=%{sysconfdir}
51 else
52   CFLAGS="$RPM_OPT_FLAGS" ./configure $ARCH_FLAGS --prefix=%{prefix} --sysconfdir=%{sysconfdir}
53 fi
54
55 %build
56 export -n LANG LINGUAS LC_ALL 
57
58 if [ "$SMP" != "" ]; then
59   (make "MAKE=make -k -j $SMP"; exit 0)
60   make
61 else
62   make
63 fi
64
65 %install
66 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
67 make prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} install
68
69 %clean
70 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(-, root, root)
74
75 %doc COPYING ChangeLog INSTALL README TODO doc/*.html doc/*.pdf doc/*.ps
76
77 %attr(0755,root,root) %{prefix}/bin/barcode
78 %attr(0644,root,root) %{prefix}/info/barcode.info*
79 %attr(0644,root,root) %{prefix}/man/man1/barcode.1*
80
81 %files devel
82 %attr(0644,root,root) %{prefix}/include/barcode.h
83 %attr(0644,root,root) %{prefix}/lib/libbarcode.a
84 %attr(0644,root,root) %{prefix}/man/man3/barcode.3*