]> git.sur5r.net Git - glabels/blob - barcode-0.98/debian/rules
Imported Upstream version 2.2.8
[glabels] / barcode-0.98 / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4
5 package=barcode
6
7 build:
8         $(checkdir)
9         ./configure --prefix=/usr
10         $(MAKE) CFLAGS="-O2 -g -Wall"
11         touch build
12
13 clean:
14         $(checkdir)
15         -rm -f build
16         -$(MAKE) distclean
17         -rm -f `find . -name "*~"`
18         -rm -rf debian/tmp debian/files* core debian/substvars
19
20 binary-indep: checkroot build
21         $(checkdir)
22 # There are no architecture-independent files to be uploaded
23 # generated by this package.  If there were any they would be
24 # made here.
25
26 binary-arch: checkroot build
27         $(checkdir)
28         -rm -rf debian/tmp
29         install -d debian/tmp
30         cd debian/tmp && install -d `cat ../dirs`
31         $(MAKE) install prefix=`pwd`/debian/tmp/usr
32 # Must have debmake installed for this to work. Otherwise please copy
33 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
34         debstd ChangeLog README TODO INSTALL
35         dpkg-gencontrol
36         chown -R root.root debian/tmp
37         chmod -R go=rX debian/tmp
38         dpkg --build debian/tmp ..
39
40 define checkdir
41         test -f debian/rules
42 endef
43
44 binary: binary-indep binary-arch
45
46 checkroot:
47         $(checkdir)
48         test root = "`whoami`"
49
50 .PHONY: binary binary-arch binary-indep clean checkroot