]> git.sur5r.net Git - bacula/bacula/blob - bacula/platforms/contrib-rpm/rpmkey.spec
Backport from Bacula Enterprise
[bacula/bacula] / bacula / platforms / contrib-rpm / rpmkey.spec
1 # rpm public key package
2 #
3 # Copyright (C) 2000-2015 Kern Sibbald
4 # License: BSD 2-Clause; see file LICENSE-FOSS
5 #
6
7 # replace the string yournam with your name
8 # first initial and lastname, ie. sbarninger
9 %define pubkeyname yourname
10
11 # replace below with your name and email address
12 Packager: Your Name <your-email@site.org>
13
14 Summary: The %{pubkeyname} rpm public key
15 Name: rpmkey-%{pubkeyname}
16 Version: 0.1
17 Release: 1
18 License: BSD 2-Clause; see file LICENSE-FOSS
19 Group: System/Packages
20 Source0: %{pubkeyname}.asc
21 BuildArch: noarch
22 BuildRoot: %{_tmppath}/%{name}-root
23
24 %define gpgkeypath /etc/bacula/pubkeys
25
26 %description
27 The %{pubkeyname} rpm public key. If you trust %{pubkeyname} component
28 and you want to import this key to the RPM database, then install this 
29 RPM. After installing this package you may import the key into your rpm
30 database, as root:
31
32 rpm --import %{gpgkeypath}/%{pubkeyname}.asc
33
34 %prep
35 %setup -c -T a1
36
37 %build
38
39 %install
40 mkdir -p %{buildroot}%{gpgkeypath}
41 cp -a %{SOURCE0} %{buildroot}%{gpgkeypath}/
42
43 %files
44 %defattr(-, root, root)
45 %{gpgkeypath}/%{pubkeyname}.asc
46
47
48 %changelog
49 * Sat Aug 19 2006 D. Scott Barninger <barninger@fairfieldcomputers.com
50 - change key directory to /etc/bacula/pubkeys
51 * Sun Jul 16 2006 D. Scott Barninger <barninger@fairfieldcomputers.com
52 - initial spec file