]> git.sur5r.net Git - bacula/bacula/blob - bacula/platforms/rpm/bacula-docs.spec
Tweak spec files
[bacula/bacula] / bacula / platforms / rpm / bacula-docs.spec
1 # Bacula RPM spec file
2 #
3 # Copyright (C) 2000-2010 Free Software Foundation Europe e.V.
4
5 # Platform Build Configuration
6
7 # basic defines for every build
8 %define _release           1
9 %define _version           5.0.3
10 %define _packager D. Scott Barninger <barninger@fairfieldcomputers.com>
11
12 %define _prefix        /usr
13 %define _sbindir       %_prefix/sbin
14 %define _mandir        %_prefix/share/man
15
16
17 #--------------------------------------------------------------------------
18 # it should not be necessary to change anything below here for a release
19 # except for patch macros in the setup section
20 #--------------------------------------------------------------------------
21
22 %{?contrib_packager:%define _packager %{contrib_packager}}
23
24 Summary: Bacula - The Network Backup Solution
25 Name: bacula-docs
26 Version: %{_version}
27 Release: %{_release}
28 Group: System Environment/Daemons
29 License: AGPLv3
30 BuildRoot: %{_tmppath}/%{name}-root
31 URL: http://www.bacula.org/
32 Vendor: The Bacula Team
33 Packager: %{_packager}
34 BuildArchitectures: noarch
35 Prefix: %{_prefix}
36 Distribution: Bacula Documentation
37
38 Source: %{name}-%{_version}.tar.bz2
39
40 # Source directory locations
41 %define _docsrc .
42
43 # define the basic package description
44 %define blurb Bacula - The Leading Open Source Backup Solution.
45 %define blurb2 Bacula is a set of computer programs that permit you (or the system
46 %define blurb3 administrator) to manage backup, recovery, and verification of computer
47 %define blurb4 data across a network of computers of different kinds. In technical terms,
48 %define blurb5 it is a network client/server based backup program. Bacula is relatively
49 %define blurb6 easy to use and efficient, while offering many advanced storage management
50 %define blurb7 features that make it easy to find and recover lost or damaged files.
51 %define blurb8 Bacula source code has been released under the AGPL version 3 license.
52
53 Summary: Bacula - The Network Backup Solution
54 Group: System Environment/Daemons
55
56 %description
57 %{blurb}
58
59 %{blurb2}
60 %{blurb3}
61 %{blurb4}
62 %{blurb5}
63 %{blurb6}
64 %{blurb7}
65 %{blurb8}
66
67 This package installs the Bacula pdf and html documentation.
68
69 %prep
70 %setup
71
72
73 %clean
74 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf "$RPM_BUILD_ROOT"
75 rm -rf $RPM_BUILD_DIR/%{name}-%{_version}
76
77 %files
78 %doc %{_docsrc}/manuals/en/console/console %{_docsrc}/manuals/en/console/console.pdf
79 %doc %{_docsrc}/manuals/en/developers/developers %{_docsrc}/manuals/en/developers/developers.pdf
80 %doc %{_docsrc}/manuals/en/main/main %{_docsrc}/manuals/en/main/main.pdf
81 %doc %{_docsrc}/manuals/en/misc/misc %{_docsrc}/manuals/en/misc/misc.pdf
82 %doc %{_docsrc}/manuals/en/problems/problems %{_docsrc}/manuals/en/problems/problems.pdf
83 %doc %{_docsrc}/manuals/en/utility/utility %{_docsrc}/manuals/en/utility/utility.pdf
84
85 %changelog
86 * Sat Jan 30 2010 D. Scott Barninger <barninger@fairfieldcomputers.com>
87 - change source file to bz2, update for new doc structure
88 * Sat Aug 1 2009 Kern Sibbald <kern@sibbald.com>
89 - Split docs into separate bacula-docs.spec